Re: [gnome-love] Can't get jhbuild to run right

El mié, 21-05-2008 a las 08:54 -0700, MHR escribió:
Greetings from a first time poster here.

I've been having some interesting difficulties getting jhbuild to run
on my CentOS 5.1 x86_64 system.  (Why would I do that at all?  Because
CentOS 5.1 comes with GNOME 2.16.0, which has been great, but it's
getting old and I'd like to get at some of the newer featuesr og GDE.)

First, jhbuild sanitycheck reports "git not found."  I've been told by
the developers that this is not a bug, or a serious problem, so that's
well and good.

It means that you should install git first. Try from packages for your
distribution, if they are available.

But now I'm getting this:

checking pkg-config is at least version 0.9.0... yes
checking for LIBBONOBO... yes
checking for SERVER... configure: error: Package requirements (
gmodule-2.0 >= 2.0.1    ORBit-2.0 >= 2.4.0      ORBit-CosNaming-2.0 >=
2.4.0    dbus-1 >= 1.0.0 dbus-glib-1 >= 0.74     libxml-2.0 >= 2.4.20)
were not met:

No package 'dbus-glib-1' found

You haven't build dbus-glib yet, and the package you are currently
trying to build needs it. Make sure that dbus-glib is built first.

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables SERVER_CFLAGS
and SERVER_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

*** error during stage configure of libbonobo: ########## Error
running ./ --prefix /opt/gnome2 --libdir
'${exec_prefix}/lib64'  --disable-static --disable-gtk-doc  ***

  [1] rerun stage configure
  [2] ignore error and continue to build
  [3] give up on module
  [4] start shell
  [5] go to stage force_checkout
  [6] go to stage force_clean
  [7] go to stage force_distclean

This is only my second time attempting to run jhbuild, and I'm going
by the instructions from the GNOME home page.  It was suggested that I
start over fresh from the beginning, because some changes were made in
this area a week or two ago, but I'm still getting the same error
after a fresh checkout of jhbuild last night.

Any suggestions?


gnome-love mailing list
gnome-love gnome org

Claudio Saavedra <csaavedra gnome org>

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]