gnome, shutdown/restart buttons do not work

Hi dear all. I am using Gnome 2.26.1 and gdm 2.20.10 and running them

Linux toyhill 2.6.29-gentoo-r1 #7 SMP Tue May 5 23:05:59 Local time
zone must be set--see zic m x86_64 Intel(R) Core(TM)2 Duo CPU E8400 @
3.00GHz GenuineIntel GNU/Linux

Today I updated gentoo and I found I could not get the shutdown/restart buttons
working properly. Every time I press either of these two buttons
through System-->
Shutdown I got the same result as Ctrl+Alt+Backspace, and I was leaded then
to the login window of gdm. If I run reboot in a terminal as root, or
I choose to restart
the machine in gdm window, everything is fine. I am not sure if it is because
these two buttons failed to find the correct scripts to switch
runlevel. I think even
telling me the principle of these two buttons would be helpful for me to solve
these two problems.. I just do not know what really happend if I press them.

Thank you.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]