Problems with wide screen and GNOME

I am running a (fully updated) CentOS 5.2 x86_64 box that has been
working just fine for over a year, with a few minor glitches (like
this one?) here and there.

I just picked up an Emprex LE22A3 (21.6" 1680x1050 WSXGA) monitor and
tried to get it work nicely with my system, and it works fine until I
login to GNOME.

During the boot, all the way up to and including the login screen, I
get the full 1680x1050 resolution, and also on the secondary consoles.

However, when I login to my GNOME desktop, the screen gets reset to
1280x1024 and refuses to work in widescreen mode at all.

I've run through every scenario I (and some of the CentOS list folks)
can think of, all kinds of tweaks to xorg.conf, even downloaded the
latest and greatest nvidia driver, and every time, without fail,
during the blackout between the login screen and the desktop, the
video gets reset.  I've tried using system-config-display and manual
tweaks, and nothing seems to shake this.  I've even rebooted (in case
it was a kudzu related thing), but no.  S-c-d shows that the monitor
is a "Generic LCD 1680x1050", but even after it sets the mode up for
16x10, it goes back to 1280x1024.  I even set it so that the only mode
listed in the Modes in xorg.conf is "1680x1050" and no go.

I went through and manually deleted all the older nvidia driver files
to make sure there was no confusion (although I'm not sure this
actually made a difference).

Is there anything I'm missing?  Some other configuration file or
record somewhere I need to tweak?



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]