Re: Unable to compile Pango 1.4.x

On Thu, 14 Sep 2006, Joona I Palaste wrote:

> On Thu, 14 Sep 2006, Jeff Waugh wrote:
> > "Joona I Palaste said"
> > >
> > > I am trying to compile the GTK+ v2.4 libraries on my rapidly becoming
> > > obsolete Linux installation at work. I was able to successfully compile
> > > Glib and ATK, but Pango is giving me errors I don't know how to fix.
> > > They happen with both Pango 1.4.0 and 1.4.1.


> Yes, I have freetype. The .pc file says it's FreeType 2, version
> 9.10.3.

Well, I switched to an earlier version of freetype, and recompiled. I
got another compiler error, but it was a simple typo. Someone had
written _pointer instead of _pointer_ in a memory reallocation macro.
I fixed that and was able to get Pango 1.4.0 compiled. But now I'm
stuck because GTK+ requires the X11 development libraries, which take
tens of megabytes. Installing them is so much work that I'm leaving it
off to tomorrow.

/--Joona Palaste-------------------------------------------------------\
\----------------------------------------------palaste cc helsinki fi--/

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]