Lost gnome-panel after installing 4.4.0 XFree86 on 9.2 AMD64

I installed the AMD64 binary version (yes, on an AMD64 system) of XFree86 4.4.0, downloaded from the XFree86.org site.  I installed on an eMachines M6805 laptop, and I'm pleased to say that I've been able to get the native 1280x800 resolution on the LCD, and I've been able to simultaneously drive an attached monitor at an independent resolution and refresh rate.  This laptop uses the ATI 9600 Mobility chip with 64 MB discrete RAM, and I'm running the RC1 Mandrake 9.2 AMD64 release.  I'm using the "radeon" driver.  ATI is very recalcitrant regarding 64-bit Linux drivers, so I've been limited to fbdev (framebuffer) until now.

The issue I'm having is with gnome-panel.  If I run without Xinerama, I only have a panel on the CRT, which I've verified by looking at XFree86.0.log is definitely the secondary monitor.  If I run with Xinerama, I have no panels at all!  I am still able to use alt-f1 to bring up the system menu, which appears in the upper right hand corner of whichever display has the input focus.  The panel must be running because it shows up in ps -ef, and if I try to run it it complains that it is already running.

I've tried bringing up Configuration-GNOME-Advanced-Sessions and configuring "Panel" so it doesn't automatically restart.  I then killed the panel and started it manually using the --screen option.  No matter what I set that to, I get the same results described above.

I'm happy to finally have dual-monitor support under 64-bit LInux, but how can I get the panel to appear on the laptop LCD?  Thanks.

Guy Rouillier

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]