Gnome freezing up during startup

I have a weird problem. I have Mandrake 9.0 with Gnome 2. Everything was working except playing Audio CDs. I saw somewhere that I should
ln -s /dev/hdd /dev/cdrom
chmod 666 /dev/cdrom
chmod 666 /dev/hdd
chmod 666 /dev/audio
It worked out - but now Gnome freezes up when it starts! Not always but 95% of the time. The worst thing is that I can't figure out why... By the way, KDE is starting just fine, but I like Gnome better. This is what happens: Gnome freezes after loading the wallpaper, before loading the panels and the icons on the desktop. It doesn't give any error messages it just freezes. I menage to start it when I reboot in the text mode and add/remove the symlink. But since I don't beleave that it has something to do with the symlink - it's probably something with the permissions (but I'm not sure). I noticed that /dev/audio keeps changing the permissions to crw-------, and now I started Gnome normaly after changing the permissions to crw-rw-rw-. But, even if it starts several times in row - it never survives this procedure: I put the Audio CD in, play it, stop it, reboot the computer - Gnome freezes during the startup...

I tried starting Gnome form console. It starts the same way, but after an successful startup, I logout and see the remaining of the warnings on the screen:
(nautilus:1547): Gtk-CRITICAL **: file ../../gtk/gtkwidget.c line 2933 (gtk_widget_event): assertion 'WIDGET_REALIZED_FOR_EVENT (widget,event)' failed

(gnome-panel:1549): Gtk-CRITICAL **: file ../../gtk/gtkwidget.c line 2933 (gtk_widget_event): assertion 'WIDGET_REALIZED_FOR_EVENT (widget,event)' failed

-- Hash table keys for warning below:
--> file:///etc/security

(nautilus:1547): Eel-WARNING **: "nautilus-directory.c:directories" hash table still has 1 element at quit time (keys above)

(nautilus:1547): Bonobo-WARNING ***: Learned a total of 2 refs to 2 bonobo object(s)
I also saw somewhere that it might be a Nautilus problem - I started the nautilus self check:

running nautilus_self_check_search_uri
running nautilus_self_check_file_utilities
running nautilus_self_check_file_operations
running nautilus_self_check_directory

FAIL: check failed in nautilus-directory.c, line 1729
     evaluated: g_hash_table_size (directories)
      expected: 1
           got: 2

And it stops responding (but I can end the process with CTRL-C).

Sorry for the big mail and
Thanks for your time and suggestions.

Relja Arandjelovic

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]