Failed dependencies on Gnome 2.0.1

Hello, everyone :)
I am attempting to install Gnome 2.0.1 from the source code and I am getting
this error when I "./configure" gtk+-2.0.6:

checking for pkg-config... /usr/bin/pkg-config
checking for glib-2.0 >= 2.0.6 atk >= 1.0.1 pango >= 1.0.1... Requested
'glib-2.0 >= 2.0.6' but version of GLib is 2.0.1

configure: error: Library requirements (glib-2.0 >= 2.0.6 atk >= 1.0.1 pango >=
1.0.1) not met; consider adjusting the PKG_CONFIG_PATH environment variable if
your libraries are in a nonstandard prefix so pkg-config can find them.

I'm sure you've heard this story before :), but "glib-2.0.6" was the first
package I configured, made and installed.  When I attempted to do the next
package, "gtk+-2.0.6", I got the above error message.  I then configured, made
and installed "atk-1.0.3" and "pango-1.0.4", and reattempted configuring
"gtk+-2.0.6", with the same results.  The problem is, all of the packages
necessary have just been installed on my system.  Oh yeah, and they were all
installed with the default path of "/usr/local"

Needless to say, I am at a loss.  If you need more complete logs, please let me
know what way you want them sent, and I will oblige.
Any help you can give me will be greatly appreciated :)

Another thing, I did successfully put "/usr/local" in my path when I
successfully upgraded to KDE 3.0.3, in case that has anything to do with my
problem.  And also, I apologize if this is a nobrainer, but rest assured, I am
willing to learn :)

Steven P. Ulrick

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]