Installation problems

I am trying to install gnome manually.  One reason for that is that I like to install all my software manually and also because my distro isn't supported by ximian or gnome.
    Any way the problem I am having is that some packages that I try to install keep giving me the following error message: 
 -ldb-3 /opt/gnome/lib/ /opt/gnome/lib/           /opt/gnome/lib/ /opt/gnome/lib/           /opt/gnome/lib/ -ldl -lXext -lX11 -lm           /opt/gnome/lib/ /opt/gnome/lib/ -lz           -L/usr/local/lib /usr/local/lib/  -Wl,-soname           -Wl, -o .libs/
          /usr/bin/ld: cannot find -ldb-3
          collect2: ld returned 1 exit status
          make[2]: *** [] Error 1
          make[2]: Leaving directory `/root/gnome-print-0.32/libgnomeprint'
          make[1]: *** [all-recursive] Error 1
          make[1]: Leaving directory `/root/gnome-print-0.32'
          make: *** [all-recursive-am] Error 2

I thought maybe it might refer to the berkley database package but I have tried both the 3.3.11 and 4.0.14 versions and I still get the error message.  So if anybody knows what this error is referring to please let me know so I can fix the problem.

Thanks in advance,

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]