Re: fxtv (STB) and audio issues -- Live!, PCI512. emu10k1

   Weird... but my card is now working (sans the rear speakers, 
natch).  If you're really interested in the steps I took in getting 
it working, read on.  After writing most of this message, I came back 
to the top to let you know that I'm going to post this for posterity 
-- so I probably get into more detail than you're interested in 
   In one of the messages I found in the archives that I mentioned to 
you, one person spoke of seeing a "/dev/dsp busy" error , or 
somenthing to that effect.  Another person recommended using syscntl 
to set hw.snd.pcm0.vchans=4 so as to eliminate the conflict.
   Well, I opened a console when trying to make some noise and found 
the same error.  sysctl showed my hw.snd.pcm0.vchans = 0, so I tried 
out the advice.  The value went from 0 to 4 -- but didn't seem to 
change anything.
   In desparation, I rebooted the box and checked hw.snd.pcm0.vchans, 
which was back to 0.  Figuring I hadn't made any headway and now 
grasping at straws, I chose a different wm (rather than 
Sawfish/Gnome) from the wdm login screen -- and it worked!  
The sound (cdcontrol and xmms) worked!  I tried every other wm -- 
including Sawfish w/ Gnome -- and I now have sound.  Go figure... 
   I am guessing that using sysctl to set the umber of dsp's to 4 
that one time (A) did something to trigger something in the card... 
or (B) maybe had some cascading effect on some default setting in a 
FreeBSD config file... or (C) Gnome and/or Sawfish was hosing the 
   I purposely tried several wm's before trying Gnome & Sawfish 
(G/S).  Then, when I started the G/S session, I had no sound effects 
(Gnome's "Sound Events"), even though those had been turned on in the 
Gnome Control Center.  (Btw, I have always had the Sawfish sound 
events turned off.)  But I started xmms (by typing "xmms" in an 
xterm) -- and it worked.  Likewise with cdcontrol.  So, I tempted 
fate and fired up the Gnome Control Center and checked my Sound 
Events; they were still turned on and I tried clicking on the [Play] 
button for some of the events -- and they actualy played.  (Just in 
response to my clicking the button in the control center -- not in 
response to the actual events, such as logging in/out, clicking on 
checkboxes, etc...)  So, on a hunch, I logged out (just to the wdm 
login screen -- I left the system running, this time) and logged back 
in again, directly to G/S.  As I did, the login wave played and 
everything seems to be working as it's supposed to (except, of 
course, for the rear speakers).
   Tempting fate yet again, I logged out of my own account (in which 
all of the above activity took place -- not root's) and logged into 
G/S, again, using another user account which had the sound events 
turned off.  I turned them on and tried to test them -- to no avail.  
(But xmms did work.)  Unfazed, I simply logged out, then back into 
G/S under that login -- and the sound events worked.
   So, for what it's worth, I should note that Gnome seems to start 
up Esound at login and keeps it running.  When I started all those 
other wm's, I checked for the presence of the Esound daemon (esd), 
and none of them started it (which makes sense, given that I don't 
have any sound events set to run via any of the wm's).  Per soemone's 
suggestion, I set up xmms to use esd, when ut didn't work w/ oss.  
Xmms will start esd, but then esd will go away when xmms is done with 
it.  I'm not sure what the connection is, but I found it curious 
that, after running that sysctl command to set the # of dsp's to 4 
and rebooting, that:
1) xmms and cdcontrol began working immediately for (presumably) any 
login (all associated dev's had open perm's, btw -- before and after 
2-a) Gnome sound events did not work upon first logging in for any 
2-b) Gnome sound events could be sampled via the [Play} button in its 
control center for the first user to log in -- but not the second and
3) Gnome sound events began working properly (reacting to events as 
well as responding to the [Play} button in the control center) with 
each user's second login after the "fix."
   (I quote "fix" because I am not convinced that running that sysctl 
command had any more of an effect on my system than some unusual 
astronomical alignment might have had by way of tugging at some 
wayward electrons in my sound card... given that I know about as much 
about the capability of either cause to have had the desired effect.)
   Well, unfortunately, this isn't very scientific in its isolation 
of the problem and/or solution (namely in that neither is really 
isolated), but I'm posting this to FreeBSD-questions and the 
Gnome-list just in case someone else comes to grasping at straws and 
might find this worth trying.  Also, perhaps someone who works on the 
associated pieces (be it Gnome, esd, the pcm driver, Sawfish0 might 
find something in this worthy of investigation.  But then... maybe 
   Now, if only I can get my ATI All-In-Wonder card going... :-)

P.S.  If anyone from the freebsd-questions list wishes to reply to 
me, please do so to my e-mail addy.  I've unsubscribed from that 
list, for now.  My time's been getting a bit pinched, lately.  Thanks.

On Monday 18 February 2002 07:05 pm, you wrote:
> Thanks for the follow-up!
> The only other thing that was mentioned to me was to look at the
> mixer(8) settings.  I was recommened to look into one of the
> settings, I believe "rec"  While that setting didn't help out, you
> may want to see what the output of mixer mentions.
> I haven't seen anything else w.r.t. to your problem, but if I do,
> I'll let you know!
> Jon
> --- Bob Giesen <BobGiesen earthlink net> wrote:
> > On Saturday 16 February 2002 08:48 am, you wrote:
> > > The last thing I noticed is that the I haven't had
> > > the pcm driver able to suppor the black "rear out jack", but
> >
> > only
> >
> > > the green "line out jack".
> >
> > Jon,
> >    You might want to check out the following FBSD
> > multimedia-archive
> > URL.   In it, the current pcm-device author, Cameron Grant,
> > mentions
> > that the rear speakers were not supported in v4.2.  Perhaps
> > they're
> > still not.
> >    You might want to poke around this archive (or even get on the
> >
> > list, if you're not, yet).  I noticed some fxtv-related subjects
> > in
> > the list.
> > Bob
> >
> > --
> > "A camel is a horse designed by a committee." -- Unknown
> __________________________________________________
> Do You Yahoo!?
> Yahoo! Sports - Coverage of the 2002 Olympic Games

Did you know... that the phrase, "in the limelight," originated in 
the 1800's, when "limelights" were used for stage illumination?  Lime 
(calcium oxide) was heated to incandescence by an oxyhydrogen flame, 
producing a bright light.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]