Re: cannot find -ldb

No, you didn't mess anything up.  Unlike most of the other path's
which can be defined in the configure phase of gnome-libs, gnome-core, and other gnome packages, BerkeleyDBis unknowingly absent. IE, we should be able to do something like:

./configure --with-berkdb=/usr/local/BerkelyDB

in gnome-libs-1.2.8.  If it worked like this, we wouldn't have this
problem, as link dirs for BerkeleyDB would get propogated out through the gnome-config script and the script.

To get around this, you can modify gnome-config and add
"-L <berkeley DB libdir>" in the cases  gnome and gnome-ui.  that
will fix later things you compile.

In the mean time, add "-L<berkeley DB libdir>" to the environment
variable LDFLAGS.  IF that doesn't work, then you'll need to hack
the Makefile and do the same modification.

One last note: if you compiled BerkeleyDB with c++ extensions, then
you have to configure gnome-libs-1.2.8 with --enable-stdcxx.



Every time I try to compile a gnome application, I get the same error
during the final linking of the program.  the compiler says:

/usr/bin/ld: cannot find -ldb

and then the make fails.
I'm guessing that I just messed up some library file that I shouldn't
have, but I have absolutely no idea which one.  What library(s) does the
-ldb flag refer to?  Anyone seen this problem before?  or have any other
insight as to what my problem is?  I running Debian Woody, and using all
of the latest helix/ximian debian packages.  thanks in advance for your


btw, I'm not subscribed to the list, so please cc dfenster umr edu in
any responses... thanks

gnome-list mailing list
gnome-list gnome org

Get your FREE download of MSN Explorer at

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]