gdm hoses gnome-terminal (or so it seems)

Hi folks,

gdm apparently causes gnome-terminal to hose special characters
(like the German ä = "a = a-umlaut). It took a while to figure it out, but
when I updated to, the gnome-terminals started from the panel
(with or without --use-factory) wouldn't show the umlauts, just spaces.
Reading mails with pine caused lines to be cut from the first umlaut to
the end of the line. XTerms and KDE konsoles worked fine, as well as
gnome-terminals manually started from another gnome-terminal, xterm or
konsole. gnome-terminals started from the "Run" dialog didn't work.
Apparently there is something different in some X settings/environment
inherited from the parent application in the panel/run dialog case.

I experimented with xfs settings a while, but to no avail.

Now why do I believe that it stems from gdm? I believe this because
everything worked fine when I started the session with "startx" or when I
downgraded to version 2.0.96 (recompiled on the current system for that

Any ideas why this could happen? Or did someone notice similar behaviour?
For the record: my system is mostly the Red Hat Linux 7.1 Public Beta
running on IA32 (AMD Athlon).

         Nils Philippsen / +49.711.96437.250 / nils redhat de
       Red Hat GmbH / Hauptstätter Straße 58 / D70178 Stuttgart
The use of COBOL cripples the mind; its teaching should, therefore, be
regarded as a criminal offence.                  -- Edsger W. Dijkstra

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]