I thought I'd try out gnome (my first time!) so I followed the
instructions on the webpage and draged over all the assorted things and
started compiling.  Well, some of the things required other things I
didn't have, so I dragged them over too, I lost track of them all.  Ok,
so now I've got nearly 12 hours of time sunk into this and I seem to
have hit a roadblock.

In trying to configure gnome-libs, there's a dependency on libdb.  I
looked through some of the archive mail and there's a pointer to the
Berkeley sleepycat libdb.  I tried this but I don't think this is the
right library.  For starters, sleepycat has db_open() instead of
dbopen() which is what the configure script is looking for.

I think it's really the gnu libc, or some subset of it that is wanted.
So, I tried to compile glibc (which isn't supported on solaris!) and
then I ran into a whole string of other dependencies like crypt and the
gnu bin utils!  I chased those down and of course, it doesn't compile
cleanly on Solaris.  There's got to be an easier way.

Can someone please tell me where I can find libdb?  And I don't think
it's part of the Linux distribution.

Even better, has someone compiled gnome for sparc/solaris 7?

Then I just saw Andy Kahn's message and now I'm worried that the ftp
site is out of date...  Anyone have a suggestion on how to get gnome up
and running to play with in the least amount of hassle, or should I just
wait a few months?

Michael Grant

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]