Some difficulties...


I have only recently started compiling apps and have
found that I have consistent problems compiling any 
app that uses gtk libs.  I have a RH 5.2 system with 
essentially all the latest official updates.  

A problem, for example, I have guile-gtk-0.14 that 
I have been trying to compile for days but I can't get 
past configure.  When I run configure, the process craps
out when it tries to run a gtktest app.  I get a 
message that gtk-config is incorrect or I have
moved the libs since installing.  Uh-uh.  I RPM'd 
gtk+-1.1.13 (and all those before it), gtk+10-1.0.6-2,
glib-1.1.13, glib10-1.0.6-2, the devel libs for 
each gtk+ and glib, as well as installed the rpm for
guile-1.3-1 and guile-devel.  

No matter, when ANY gtk-dependent app in configure tries
to run a gtktest app, I get the same error.  Exactly what
is supposed to be altered/edited in gtk-config in order to
eliminate this error message?

As for guile...I cannot get configure to see guile on
my system.  If I run ./configure --disable-gtktest, I get
past the test app snag but then configure craps out with
"can't find guile on your system"  or something similar.
It IS on my system.  The lib locations are in,
the location is also in the PATH.  

In each case mentioned, I have tried several configure 
switches to explicitly point to my gtk libs and guile,
all to no avail.  This gtk-config-related problem occurs
on EVERY gtk app I have tried to compile.  

Thank you for any aid on this.  It is drivin' me nuts.
"If a man hasn't discovered something that
he will die for, he isn't fit to live."
	          --Martin Luther King, Jr

Padraig UiNiall

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]