Re: gmc and icons and command bindings

On Wed, Jan 27, 1999 at 09:25:54PM -0600, Miguel de Icaza wrote:
> Could you find which regexp is matching?  Because that is only a
> workaround, I would like to find the real source for the problem.

It looks like regexec is called with a NULL pointer each and every time:

gnome_mime_type_or_default() ext='h'
g_hash_table_lookup() prio='1', ext='h'
********* filename=tree.h, mp->regex=(null)
mimetype='(null)', filename='tree.h'

Do all the nice icons that come per default work for you?
All the screenshots with gmc i've ever seen don't have anything other
than the "unknown" icons and directory icons, although they should
have a lot of different ones.

Anyway, I must admit, I tried to narrow the problem in the first place.
I am still not too familiar with the internal design concepts of gnome
and all the stuff.

I have jumped into the code, located what I thought might be the problem
and found a workaround.

I think there should be a test for an empty regexp, as - at least on
FreeBSD - it seems to match everything.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]