Re: Help Compilation problems. (LONG!)

On Thu, 14 Jan 1999, Chris Replicant Steinke wrote:
> Hi
> I am in need of some assistance/advice or be pointed 
> in the right direction. 
> I'm not accessing the source through CVS, though maybe I should.
> My system is RedHat 5.1 Linux/AMD-K6-300 box. 
> I have tried to compile the gnome-core a number of times
> and have tried different versions. 
> gnome-core-0.99.2 is the current version that I have attempted.
> I tried just downloading the source and compiling, then I 
> tried to install from the RPM source distribution. 
> I downloaded Gnome from my closest mirror here in Japan.

Get the 0.99.3 tarballs from your local mirror.  The 
gnome-core-0.99.2.tar.gz tarball had some serious compile problems.  They
look just like the errors you described.

> p.s.
> I just downloaded the(latest) gnome-core- package just to
> make sure I 
> was using the latest and ran configure and received the following errors
> when it was generating the makefiles.
> creating applets/gen_util/Makefile
> creating applets/batmon/Makefile
> sed: can't read ./applets/batmon/ No such file or directory
> creating applets/bussign/Makefile
> sed: can't read ./applets/bussign/ No such file or directory
> creating applets/cdplayer/Makefile
> Should these be in there? (batmon and bussign) I THINK I have all the
> dependencies. 
> I tried to compile and this time the compile didn't fail, but I received
> the following
> errors when it was compiling the windows.c file.
> gcc -DHAVE_CONFIG_H -I. -I. -I.. -I/usr/local/include -I../intl
> -I../intl -I/usr/local/include -DNEED_GNOMESUPPORT_H
> -I/usr/local/lib/gnome-libs/include -I/usr/local/lib/glib/include
> -I/usr/X11R6/include -DGNOMEHELPPATH=\""/usr/local/share/gnome/help\""
> -DGNOMELOCALEDIR=\""/usr/local/share/locale\"" -DVERSION=\""0.99.3"\"
> -I/usr/X11R6/include -I/usr/local/lib/glib/include -I/usr/local/include
> -g -O2 -Wall -Wno-unused  -c window.c
> window.c:128: warning: implicit declaration of function

Looks like you need to install the gnome-libs 0.99.3 tarball first. That
macro was added January 7, so I doubt it was in the 0.99.2 tarball.

Best of Luck,

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]