test-gnome dumps core for antialiased canvas


I tried to use the anti-aliased canvas in test-gnome, but it core dumped with a
floating point exception.  When I run it, everything except the aa canvas tab
works.  When I click on the aa canvas tab, the widgets show briefly before the
core dump, but nothing is visible on the canvas (the effect is momentary).

I've got a backtrace, but it doesn't exactly look informative.


[lyndon@r test-gnome]$ ./test-gnome 
Floating point exception (core dumped)
[lyndon@r test-gnome]$ gdb test-gnome
GDB is free software and you are welcome to distribute copies of it
 under certain conditions; type "show copying" to see the conditions.
There is absolutely no warranty for GDB; type "show warranty" for details.
GDB 4.16 (i386-unknown-freebsd), 
Copyright 1996 Free Software Foundation, Inc...
(gdb) core test-gnome.core 
Core was generated by `test-gnome'.
Program terminated with signal 8, Floating point exception.
Cannot access memory at address 0x20110080.
#0  0x201be77d in ?? ()
(gdb) bt
#0  0x201be77d in ?? ()
#1  0x201c6060 in ?? ()
#2  0x201bdad7 in ?? ()
#3  0x20135025 in ?? ()
#4  0x2012fef4 in ?? ()
#5  0x201270b3 in ?? ()
#6  0x201270b3 in ?? ()
#7  0x201296c4 in ?? ()
#8  0x20129996 in ?? ()
#9  0xd761d in g_idle_dispatch (source_data=0x167f30, current_time=0xefbfd9e8, 
    user_data=0x14ee00) at gmain.c:919
#10 0xd6be2 in g_main_dispatch (current_time=0xefbfd9e8) at gmain.c:390
#11 0xd6f13 in g_main_iterate (block=1, dispatch=1) at gmain.c:574
#12 0xd6fe9 in g_main_run (loop=0x143390) at gmain.c:618
#13 0x5223f in gtk_main () at gtkmain.c:458
#14 0xad59 in main (argc=1, argv=0xefbfdb18) at testgnome.c:1808
(gdb) q

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]