Re: GMC/MC problems SOLVED :-)

For anyone who was experiencing either of the problems I described in
this thread, they both have been solved.  I am posting the solution FYI.

The prbolems were:
  * GMC was segfaulting in the metadata_get_list function
  * MC (the command line version) was just giving me a blank screen
The details of the errors are in

The GMC problem was due to a remnant from, I believe, an older GMC 
version.  Some program put a link from "~/directory/Home directory" to
"~". GMC was choking on this link quite ungracefully.  I removed the link,
and it works fine now.  However, GMC really should have handled it without
a segfault, I would call this a bug.

The MC problem was solved with the kind help of Norbert Warmuth, from the
mc-devel list.  There was some communication snafu between libslang and my
terminfo database.  I reinstalled both slang and ncurses (I'm on a RedHat
system, terminfo is in the ncurses package), and it works fine now.  Since
it was a terminfo problem, I don't see how MC could have handled it any
better.  I'm surprised other programs weren't giving me trouble, Jed uses
both slang and terminfo, and I use that constantly.

Thanks to everyone for their help.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]