gnome-glue.c compile fails (gnome-guile)

I have successfully compiled the modules up through gnome-core
in the order suggested by the list in the documentation.
I started with the Jan 2 CVS sources for everything, and tried
a few of the older gnome-guile sources from the last few weeks.

The Jan 2 sources worked the best, as expected. The errors are
below. I gathered from the list archives that gnome.defs and
gnome.defs.guile have had problems lately, but I didn't see
these errors mentioned in any of the messages.



Making all in guile-gnome
make[2]: Entering directory `/usr/src/gnome/gnome/gnome-guile/guile-gnome'
/bin/sh ../libtool --mode=compile /usr/bin/egcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I./.. -I../guile-gtk -I./../guile-gtk -I/opt/gnome/include -I/opt/gnome/include -DNEED_GNOMESUPPORT_H -I/opt/gnome/lib/gnome-libs/include -I/opt/gnome/lib/glib/include -I/usr/X11R6/include -I/usr/include  -O3 -c gnome-glue.c
/usr/bin/egcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I./.. -I../guile-gtk -I./../guile-gtk -I/opt/gnome/include -I/opt/gnome/include -DNEED_GNOMESUPPORT_H -I/opt/gnome/lib/gnome-libs/include -I/opt/gnome/lib/glib/include -I/usr/X11R6/include -I/usr/include -O3 -Wp,-MD,.deps/gnome-glue.p -c -fPIC -DPIC gnome-glue.c
gnome-glue.c: In function `sgtk_gnome_canvas_group_xpos':
gnome-glue.c:1511: structure has no member named `xpos'
gnome-glue.c: In function `sgtk_gnome_canvas_group_ypos':
gnome-glue.c:1528: structure has no member named `ypos'
gnome-glue.c: In function `sgtk_gnome_canvas_root':
gnome-glue.c:1609: warning: assignment from incompatible pointer type
make[2]: *** [gnome-glue.lo] Error 1
make[2]: Leaving directory `/usr/src/gnome/gnome/gnome-guile/guile-gnome'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/gnome/gnome/gnome-guile'
make: *** [all-recursive-am] Error 2


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]