gnome freezes up my xserver

Ok, I spent most of last night compiling and installing the
needed gnome packages according in the order specified by the
website.. And it worked great like the first 2 times I brought up
X. Ever since then it has frozen my X display. I've tried rebooting,
clearing out the contents of ~/.gnome and ~/.gnome-private. I've
tried using different window managers. I even changed my xserver
from AcceleratedX to Xfree86 Basically what happens is the
window manager comes up, then nothing really happens for about 5-6
seconds, then my desktop turns color (orangeish or something I think)
then it hangs.  I can move the mouse around still, and if I have an
xterm up I can still type in it. Although I can't move the windows
around or anything.

I'm not sure where to go from here, I don't really see any log
files from gnome anywhere.. I did capture the output of startx
but that doesn't seem to useful.. 

I could use some ideas on how to figure out what is wrong...

I installed everything under /usr/local/unstable
my LD_LIBRARY_PATH and PATH are all set correctly.. 

Here are the versions for some of the stuff I have installed:

orbit-config --version
ORBit 0.3.96

gnome-config --version
gnome-libs 0.99.7

glib-config --version

gtk-config --version

audiofile-config --version

imlib-config --version

libgtop-config --version

Here is the output from startx:

      sis5597, sis5598, sis6326, tvga8200lx, tvga8800cs, tvga8900b,
      tvga8900c, tvga8900cl, tvga8900d, tvga9000, tvga9000i, tvga9100b,
      tvga9200cxr, tgui9400cxi, tgui9420, tgui9420dgi, tgui9430dgi,
      tgui9440agi, cyber9320, tgui9660, tgui9680, tgui9682, tgui9685,
      cyber9382, cyber9385, cyber9388, cyber9397, cyber9520, 3dimage975,
      3dimage985, clgd5420, clgd5422, clgd5424, clgd5426, clgd5428,
      clgd5429, clgd5430, clgd5434, clgd5436, clgd5446, clgd5480, clgd5462,
      clgd5464, clgd5465, clgd6205, clgd6215, clgd6225, clgd6235, clgd7541,
      clgd7542, clgd7543, clgd7548, clgd7555, clgd7556, ncr77c22, ncr77c22e,
      cpq_avga, mga2064w, mga1064sg, mga2164w, mga2164w AGP, mgag200,
      mgag100, oti067, oti077, oti087, oti037c, al2101, ali2228, ali2301,
      ali2302, ali2308, ali2401, cl6410, cl6412, cl6420, cl6440, video7,
      ark1000vl, ark1000pv, ark2000pv, ark2000mt, mx, realtek, s3_virge,
      AP6422, AT24, AT3D, s3_svga, NM2070, NM2090, NM2093, NM2097, NM2160,
      NM2200, ct65520, ct65525, ct65530, ct65535, ct65540, ct65545, ct65546,
      ct65548, ct65550, ct65554, ct65555, ct68554, ct69000, ct64200,
      ct64300, mediagx, V1000, V2x00, p9100, spc8110, generic
(using VT number 7)

XF86Config: /etc/XF86Config
(**) stands for supplied, (--) stands for probed/default values
(**) XKB: keycodes: "xfree86"
(**) XKB: types: "default"
(**) XKB: compat: "default"
(**) XKB: symbols: "us(pc101)"
(**) XKB: geometry: "pc"
(**) XKB: keymap: "xfree86(us)" (overrides other XKB settings)
(**) XKB: rules: "xfree86"
(**) XKB: model: "pc101"
(**) XKB: layout: "us"
(**) Mouse: type: PS/2, device: /dev/mouse, resolution: 100
(**) Mouse: buttons: 3
(**) SVGA: Graphics device ID: "Matrox Millennium G200"
(**) SVGA: Monitor ID: "Sony"
(**) FontPath set to "/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/75
(--) SVGA: PCI: Matrox MGA G200 AGP rev 1, Memory @ 0xfc000000, 0xf4200000
(--) SVGA: Linear framebuffer at 0xFC000000
(--) SVGA: MMIO registers at 0xF4200000
(--) SVGA: Video BIOS info block at 0x000c7a60
(--) SVGA: Found and verified enhanced Video BIOS info block
(!!) SVGA: Unable to probe for video memory size.  Assuming 8 Meg.      Please s
pecify the correct amount in the XF86Config file.       See the file README.MGA 
for details.
(--) SVGA: detected an SGRAM card
(--) SVGA: chipset:  mgag200
(--) SVGA: videoram: 8192k
(**) SVGA: Option "dac_8_bit"
(**) SVGA: Using 24 bpp, Depth 24, Color weight: 888
(--) SVGA: Maximum allowed dot-clock: 250.000 MHz
(**) SVGA: Mode "1280x1024": mode clock = 135.000
(--) SVGA: Virtual resolution set to 1280x1024
(--) SVGA: SpeedUp code selection modified because virtualX != 1024
(--) SVGA: Using hardware cursor
(--) SVGA: Read OPTION 0x4007cd21
(--) SVGA: Using XAA (XFree86 Acceleration Architecture)
(--) SVGA: XAA: Solid filled rectangles
(--) SVGA: XAA: Screen-to-screen copy
(--) SVGA: XAA: 8x8 color expand pattern fill
(--) SVGA: XAA: CPU to screen color expansion (TE/NonTE imagetext, TE/NonTE poly
(--) SVGA: XAA: Using 10 128x128 areas for pixmap caching
(--) SVGA: XAA: Caching tiles and stipples
(--) SVGA: XAA: General lines and segments
(--) SVGA: XAA: Dashed lines and segments
Imlib Init
Priority 00 : Starting    Id = default0
Priority 00 : Cloning     Id = default0
Priority 00 : Registering Id = 11c702128a000091897085400000284370000
Priority 05 : Starting    Id = default2
Priority 05 : Cloning     Id = default2
Priority 05 : Registering Id = 11c702128a000091897085500000284370001
Priority 10 : Starting    Id = default3
Imlib Init
Imlib Init
Priority 10 : Purging     Id = default3
Priority 20 : Starting    Id = default8
Priority 20 : Starting    Id = default7
Priority 20 : Starting    Id = default6
Priority 20 : Starting    Id = default5
Priority 20 : Starting    Id = default4
Priority 20 : Cloning     Id = default8
Priority 20 : Registering Id = 11c702128a000091897088600000284370002
SetKbdSettings - type: 2 rate: 5 delay: 500 snumlk: 0
SetKbdSettings - Succeeded
Priority 20 : Cloning     Id = default7
Priority 20 : Registering Id = 11c702128a000091897088600000284370003
Screen saver command: xscreensaver -no-splash >/dev/null 2>&1
Priority 20 : Cloning     Id = default6
Priority 20 : Registering Id = 11c702128a000091897088600000284370004
Priority 20 : Cloning     Id = default5
Priority 20 : Registering Id = 11c702128a000091897088600000284370005
Priority 20 : Cloning     Id = default4
Priority 20 : Registering Id = 11c702128a000091897088600000284370006
Priority 40 : Starting    Id = default9
Gdk-Message: Got event for unknown window: 0

Priority 40 : Cloning     Id = default9
Priority 40 : Registering Id = 11c702128a000091897088600000284370007
Priority 50 : Starting    Id = default11
Priority 50 : Starting    Id = default10
xinit:  connection to X server lost.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]