glib.h: g_rarray_append <-> ORBit

Hi gnomes,

last night I run in trouble with my lovely gnome, while
the compile of my last update from the anoncvs worked fine
(glib, gtk+, imlib, ORBit, gnome-libs, gnome-core, all with no tags, just 
plain checkout a while ago and the an update) I can't start the panel:

panel: error loading shared libraries
: missing symbol g_rarray_append

This is right, g_rarray_append is neither in glib nor in the rest
of the sources, I simply didn't find it!

So I took a look at and there it
is... So I hacked something to get the sources from,
which worked (I have no cvs acces just http). 
And then I compiled glib, gtk+, imlib, and ORBit and
ORBit got stucked with some call from glib which now has 3 args and
in ORBit it uses only 2 args, was something with g_bar(foo, type, bla) and
was g_bar(foo, bla). Sorry for beeing so unprecise, but as allways worng
computer and no access.

I CVS out of sync?? Or has any body any hints???



      Ph. Grau <> Technische FH Wildau
                     Wildau, Brandenburg, Germany

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]