Re: Gnome/RedHat Questions

"Gene C." <> writes:
> This is addressed to the folks at Red Hat who are working on gnome:
> After running across some references to Gnome, I thought that it sounded
> good and wanted to give it a try.  I am currently running rhl 5.0 with all
> current fixes applied (as of 4/18).  I have a separate partition where I
> test stuff as major as gnome so that it does not impact my production system.
> I have no idea if any of the folks at Red Hat Labs who are working on Gnome
> have tried to install and run Gnome from the rpm's on
> but my impression is that they have NOT.

On the contrary, we use them every day.

[ errors running GNOME apps ]

These are simply the evidence that GNOME is a work in progress.
The RPMs are direct build from CVS - if it's broken in CVS, it'll
be broken in the RPMs too.  That's why they are in "devel/" :-).

> 3. OK, since I like using rpm to build my binaries, I figured I would use
> it to rebuild gnome-core.  But first, lets try to at least compile the
> gnome-core source in the gnome-core-0.13*.src.rpm -- 
> 	a) first, my "current" rpm did not like the gnome-core.spec (the readme
>  in
> the devel directory mentions rpm 2.4.104 --- WHERE IS THIS???)

> 	b) Just to get it to sort of work, I commented out the offending line a
> nd
> tried again -- this time, it proceeded (boy, it it compute bound) until it
> could not find an executable called "mico-c++".
> What goes???  Have you folks forgotten you have some stuff installed which
> IS REQUIRED to rebuild the binaries?

No, you need to install the mico RPMs.

> I suspect that I am not alone in having these problems.  We can't help in
> porting/creating applications if we cannot get the environment up and working
> .

I know it's challenging.  If you are having trouble the best way to
get started is to first read  You'll
want to install *all* the RPMs in the "devel/" directory as well as
the stuff in "support/".  From there you can check out the CVS tree
and work on it, or start building your own GNOME apps.

> Please pause and try installing on a "fresh" linux system.

We do.  Frequently. 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]