problems building libgnomecanvas in win32


I'm trying to compile libgnomecanvas under win32. I did it succesfully
in a vmware box with Windows 98 but when I tried to do the same in
another native Windows 98 machine i have a problem.

I can build and install libart and libglade, which are not in the gtk
packages for win32. But when it's time to compile the libgnomecanvas I
have problems in the link phase. It seems that the configure script does
not generate a good libtool script because when linking the
libgnomecanvas i get this error:


/bin/sh ../libtool --mode=link gcc -mno-cygwin -fnative-struct
-I/c/local/include -I/c/local/include/freetype2 -fnative-struct -o -rpath /c/local/lib -no-undefined -version-info
200:0:200 gnome-canvas-shape.lo gnome-canvas.bpath.lo
gnome-canvas-path.def.lo gnome-canvas-clipgroup.lo gnome-canvas-line.lo
gnome-canvas-pixbuf.lo gnome-canvas-rich-text.lo gnome-canvas-util.lo
gnome-canvas-widget.lo gnome-canvas.lo libgnomecanvastypes.lo
-LC:/LOCAL/lib -lgtk-win32-2.0 -lgdk-win32-2.0 -latk-1.0
-lgdk-pixbux-2.0 -lpangowin32-1.0 -lgdi32 -lart_gpl_2 -lpangoft2-1.0
-lpango-1.0 -lgobject-2.0 -lgmodule-2.0 -lglib-2.0 -lintl -liconv
extracting exported symbol list from 'libart_lgpl_2-2.dll'
test -f .libs/impgen.c || \
      sed -e "/^# \/\* impgen\.c starts here \*\//,/^# \/\* impgen.c
ends here \*\// { s/^# //;s/^# *$//; p; }" -e d < ../libtool >
      test -f .libs/imgpen.exe || (cd .libs && \
      if test "x" != "x" ; then -o impgen impgen.c ; \
      else gcc -o impgen impgen.c ; fi)
      .libs/impgen /c/local/lib/libart_lgpl_2-2.dll >
c:/mingw/bin/../lib/gcc-lib/mingw32/2.95.3-6/../../../libmingw32.a(main.o)(.text+0x8d):main.c: undefined reference to 'WinMain 16'
../libtool: .libs/impgen: No such file or directory
make[2]: ** [] Error 127


The problem is that the libtool script in the libgnomecanvas directory
does not have the impgen small program inside it so the sed line does
not generate anything and the compilation of the .libs/impgen.c fails.

What I would like to know is why in my first build (the one with Win98
in vmware) the configure script did create a proper libtool. I can't
really remember if I did something different in both builds. In other
words, what things does configure depends on in order to create a proper
libtool script?

By the way, I'm using the mingw 1.1 compiler, the msys 1.0.7 and the
libgnomecanvas I run the configure with the --prefix=/c/local
flag. Before running the configure script i set the followin CFLAGS:

export CFLAGS="-mno-cygwin -fnative-struct -I/c/local/include

Any clue?

Thanks in advance

Lorenzo Gil

NOTE: when i fix this problem i will write a detailed recipe of how i
build it and probably will put available binary and development packages
of libgnomecanvas for win32

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]