Re: libgnomeprintui-2.2 ?

Le ven 29/11/2002 à 13:12, Thomas Vander Stichele a écrit :
> Hi,
> on a fresh jhbuild, gedit needs libgnomeprintui-2.2.pc and the gnome-2-0 
> branch of libgnomeprintui installs -2.0.pc  and thus the build fails.
> Now, the questions:
> a) is libgnomeprintui supposed to be API-stable ? If so, why does it not
>    keep providing libgnomeprintui-2.0.pc ? Is it just a matter of 
>    cosmetics ? I have a hunch pc files like this should have been called
>    .2.pc instead of .2.0.pc from the start ;)
>    If there is no real API change, I'd suggest that libgnomeprintui goes
>    back to using -2.0.pc, and just increase the version number

libgnomeprint AND libgnomeprintui 2.1.x are not API nor ABI compatible
with 2.0.. That is why Chema bumped the minor version for pkgconfig..

Basicaly, to convert to 2.2, you need to do a search/replace on

> b) does gedit really *need* API-incompatible functions from 
>    libgnomeprintui 2.1.x ?

I think Paolo choosed to use the latest version of libgnomeprintui..

I've already "ported" gthumb to libgnomeprintui 2.2 and I plan to do the
same for gal2 and gtkhtml..

Frederic Crozat <fcrozat mandrakesoft com>

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]