Test versions of LibGTop 1.0.7, LibGTop 1.1.5 and GTop 1.0.7

Hello guys,

I will be very busy at the university this week and absend most time of
it, so I need a little help with the LibGTop 1.0.7, 1.1.5 and GTop 1.0.7
tarballs for that GUADEC CD-ROM.

There are test versions available at:


You'll find there:

* libgtop-1.0.7.tar.gz:

  This is a test version of LibGTop 1.0.7 (the version that everybody
  should use). It contains some bug fixes both in the Linux and the *BSD
  sysdeps code.

* libgtop-1.1.5.tar.gz:

  This is a developer's snapshot of the latest LibGTop from CVS HEAD.
  It is still a bit "unstable" (and not binary-compatible to OG), but
  it should basically work on Linux and BSD.

* gtop-1.0.7.tar.gz:

  This is a test version of GTop 1.0.7. It contains a lot of bug fixes
  and also the first version of the GTop Documentation from Telsa Gwynne.

As I already said I don't have much time this week since I'll write an
exam at the university on Friday and all stuff for the GUADEC CD must
be ready until Tuesday - so I'd be very happy if some people could test
the following things:

1.) LibGTop 1.0.7 must compile on all supported systems (that are all
    flavors of Linux, FreeBSD, NetBSD and OpenBSD) and GTop 1.0.7 must
    not produce a core dump with it (of cause, if it displays wrong
    data and someone has a fix I'd be very happy).

2.) LibGTop 1.1.5 _should_ compile on recent GNU/Linux systems (means it
    may break on libc5 or other older ones) - but it should compile on
    recent Debian, RedHat and SuSE systems. It should also compile on
    FreeBSD, NetBSD and OpenBSD, but I only tested it on NetBSD 1.4.1.

    The Solaris port doesn't work at the moment and I'll involve more than
    a 10-line patch to fix it, so it's safe to assume that this can't be
    done for the upcoming release.

3.) GTop 1.0.7 must compile with both version of LibGTop (so if you managed
    to get LibGTop 1.1.5 installed and GTop doesn't compile, then this is
    a bug). It _should_ work with LibGTop 1.1.5 on recent GNU/Linux systems
    and on *BSD. However, I only tested it on NetBSD 1.4.1.

    Since I added Telsa's documentation, there is some pseudo-dependency on
    docbook and the gnome dtd stuff with pnp support from


    However, this must not cause compilation from CVS to abort on any system
    if you don't have the docbook stuff or if you only have the "plain"
    docbook stuff (without png) support.

    Someone needs to try this out at least on Debian, RedHat, SuSE and FreeBSD.

    The released tarball must compile and install correct documentation on any
    system, this also needs to be tested.

4.) A little RFC (Request for Comments) and a RFWS (Request for Wishlist

    Even if it's too late for this release - if you have any comments on
    the API of LibGTop 1.1.x or want to have some feature in for 1.2.0,
    let me know ....

Any comments and bug reports are very apreciated and thanks in advance for
all help with the testing ....

Btw. I'll do the final libgtop and gtop tarballs for the CD on Tuesday late
evening (European time).

Martin Baulig - martin@home-of-linux.org - http://www.home-of-linux.org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]