[gnome-db] Installing libgdamm-3.99.21


I have developed an application in Linux environment and now i wish to test it in windows environment. I use msys for compiling the libgdamm-3.99.21. After solving dependencies problems, i have succeeded to compile and install the libgdamm. But now when i want to use it i have an error.
I use CMAKE for compiling my project.
I have define the libgdamm-4.0 dependency in the CMakeList.txt
I have added the link of libgdamm-3.99.21 in the�PKG_CONFIG_PATH�env variable :

When i run the following command line : pkg-config --libs --cflags libgdamm-4.0 i get this :
$ pkg-config --libs --cflags libgdamm-4.0
-mms-bitfields -IC:/gtkmm/include/glibmm-2.4 -IC:/gtkmm/lib/glibmm-2.4/include -
IC:/gtkmm/include/sigc++-2.0 -IC:/gtkmm/lib/sigc++-2.0/include -IC:/gtkmm/includ
e/glib-2.0 -IC:/gtkmm/lib/glib-2.0/include -IC:/gtkmm/include/libxml2 -I$(top_bu
ilddir)/C:/gtk/libgdamm-3.99.21/libgdamm-3.99.21/libgda -I$(top_builddir)/C:/gtk
/libgdamm-3.99.21/libgdamm-3.99.21/libgda/. -I/usr/local/include/libgda-4.0 -I/u
sr/local/include/libgda-4.0/libgda �$(top_builddir)/C:/gtk/libgdamm-3.99.21/libg
damm-3.99.21/libgda/libgdamm/libgdamm-4.0.la -LC:/gtkmm/lib -L/usr/local/lib -lg
libmm-2.4 -lgda-4.0 -lsigc-2.0 -lgobject-2.0 -lxml2 -lgthread-2.0 -lglib-2.0 -li

(there is $(top_buildir) this is correct ?)

When i compile my project, the libgdamm.h file is not found :
$ make
[ �4%] Building CXX object src/CMakeFiles/compte.dir/main.cpp.obj
In file included from c:/compte/trunk/compte/compte_c++/gtkmm/src/service/operat
� � � � � � � � �from c:/compte/trunk/compte/compte_c++/gtkmm/src/treeview_opera
� � � � � � � � �from c:/compte/trunk/compte/compte_c++/gtkmm/src/main_view.h:5,

� � � � � � � � �from c:/compte/trunk/compte/compte_c++/gtkmm/src/main.cpp:1:
c:/compte/trunk/compte/compte_c++/gtkmm/src/service/sql_manager.h:5:22: fatal er
ror: libgdamm.h: No such file or directory
compilation terminated.
make[2]: *** [src/CMakeFiles/compte.dir/main.cpp.obj] Error 1
make[1]: *** [src/CMakeFiles/compte.dir/all] Error 2
make: *** [all] Error 2
I am wondering if i have installed correctly the libgdamm. I have use this command line :
./configure && make && make install
it's correct ?

when i tried to compile the simple example provided by libgdamm, i get the same error :
$ g++.exe -o main main.cc `pkg-config --libs --cflags libgdamm-4.0`
g++.exe: $(top_builddir)\C;C:\MinGW\msys\1.0\gtk\libgdamm-3.99.21\libgdamm-3.99
21\libgda\libgdamm\libgdamm-4.0.la: Invalid argument
main.cc:22:22: fatal error: libgdamm.h: No such file or directory
compilation terminated.

Well i have not installed correctly the libgdamm ?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]