Re: [gnome-db] libgda-4.0.1 under MinGW/MSYS

2009/4/1 Vivien Malerba <vmalerba gmail com>

2009/4/1 Brecht Sanders <brecht sanders org>

I tried to build libgda-4.0.1 under MinGW/MSYS on Windows.
I managed to build it (although only the static version), but one change was needed to avoid the

I still did not have the time to check why the DLL aren't built...
redefinition of type uint8_t. 

Below is the patch I used.
Why is uint8_t defined there anyway? Are there other win32 targets that don't have it at that point?

It's redefined because I used some code from a RFC to compute the HMAC_MD5 transformation which needs it.

--- tools/web-server.c  Tue Mar 24 20:41:30 2009
+++ tools/web-server.c  Wed Apr  1 13:48:55 2009
@@ -477,3 +477,3 @@

-#ifdef G_OS_WIN32
+#if defined(G_OS_WIN32) && !defined(__MINGW32__)
typedef guint8 uint8_t;

I finally tried the native Windows XP compilation and I've managed to make it compile the DLL by defining the missing OBJDUMP environment variable:
export  OBJDUMP=objdump
./configure .....

Note that I found that to debug the libtool script it's usefull to add "set -x" at the beginning...

However I had to let the tools/web-server.c as it currently is (that is without your patch) because it did not know the uint8_t type otherwise.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]