Re: [gnome-db] libgnomedb requires GTK+ 2.10

On 1/17/07, Murray Cumming <murrayc murrayc com> wrote:
On Wed, 2007-01-17 at 11:11 +0100, Murray Cumming wrote:
> On Wed, 2007-01-17 at 10:12 +0100, Murray Cumming wrote:
> > > Could you instead modify the file to detect GTK+ version
> > > and then #ifdef the 2.10 specific part depending on the version of
> > > GTK+? This would help me because I want to remove the GnomeDruid usage
> > > (use GtkAssistant instead), and I could use the same method.
> >
> > OK. But I can just use the existing GTK_MINOR_VERSION macro.
> >
> > I really doubt that GtkLinkButton is a sensible thing to use for this
> > GnomeDbTransactionStatus UI anyway, but I don't know how to see it in
> > the test.
> I have done that.
> I also noticed that the new picture stuff uses glib/gbase64.h, which is
> only in glib 2.12. We really need an alternative for that, or we need to
> ifdef out whatever needs it.

Actually, I now see that there is a local copy of that file, so I guess
that this bug is just old:

Yes, good thing would be to remove that file and enable BASE64
encoding only if glib version >= 1.12 using #ifdef macros. I'll do


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]