On 9/26/06, Daniel Espinosa <esodan gmail com> wrote:
I had to modify the Gda.metada in order to compile the Gda# binding, this becouse there are conflicts with _get_type and get_g_type, functions. The changes are the following: In GdaColumn Rename the method SetGType to SetValueType In libgda the function is gda_column_set_g_type In GdaColumn Rename method GetGType to GetValueType In libgda the function is gda_column_get_g_type In GdaDictType Rename method SetGType to SetValueType In libgda the function is gda_dict_type_set_g_type In GdaDictType Rename the method GetGType to GetValueType In libgda the function is gda_dict_type_get_g_type GdaServerProviderHandlerInfo Rename the member GType to ValueType In libgda the member is GType g_type What's the Point? You may want to change the name of that functions from g_type to value_type, in order to have more consistency and clarify the function action.
I'm absolutely no expert in C#, but I don't understand why there is a naming conflict in C# when there is none in C. Anyway I'll do the Gda# modifications as suggested above, and keep the C API as it's now: ...get_g_type() to get the GType of something and ...get_dict_type() to get the GdaDictType of something, and get_dbms_type() to get the DBMS type as a string. As an attachment, see the DIFF file I plan to commit and tell me if there is anything wrong with it. Thanks, Vivien
Attachment:
DIFF
Description: Binary data