Re: [gnome-db] transaction changes.



On Thu, 2006-11-16 at 09:23 +0100, Vivien Malerba wrote:
On 11/16/06, Bas Driessen <bas driessen xobas com> wrote:
>
>  Hello,
>
>  Apparently the transaction section has been completely reworked and have to
> adjust my code for it. So how do i migrate this:
>
>  -1 Rename GdaTransaction  to GdaTransactionStatus
>  -2 Rename gda_transaction_new to gda_transaction_status_new
>  -3 Isolation level.... If in my old code I set:
>
>  gda_transaction_set_isolation_level (trans,
> GDA_TRANSACTION_ISOLATION_SERIALIZABLE);
>
>  How do I set this in the new situation as I can't find a similar named
> function?
>
>  -4 what else?
>

The transaction model was difficult to use and to understand (I had
problems ubderstanding it while reading the code), so I decided to
change it in a way that it's easier to use and understand.

Your code should now take into account that:
* to start a transaction, use gda_connection_begin_transaction(), and
use the other similar functions to commit it or roll it back.
* no need for a GdaTransaction object anymore
* the GdaCommand object has no notion of transaction, it's the
connection which is used to execute the command which may be or not in
a transaction.

Moreover, support for save points has been added for the providers
which support them, and a new GdaTransactionStatus object has been
added which helps keep track of the "transactional status" of a
connection: it lists the started transaction, the savepoints, the
sub-transactions and the queries which have been run while in a
transaction.

I'm sorry there is not yet any doc for that, it's on my TODO list when
the work is finished around the new transaction model.

Thanks Vivien. Trying/testing the changes you are suggesting now.

Bas.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]