Re: [gnome-db] libgda/libgnomedb 1.3.0 released

Bas Driessen said:
> On Tue, 2005-02-08 at 21:22 +1100, Robert Bertram wrote:
>> Rodrigo Moya said:
>> > libgda/libgnomedb are a complete framewok for developing
>> > database-oriented applications, and currently allow access to
>> PostgreSQL,
>> > MySQL, Oracle, Sybase, SQLite, FireBird/Interbase, IBM DB2, mSQL and
>> MS
>> > SQL server, as well as MS Access and xBase files and ODBC data
>> sources.
>> >  ...
>> Hi all,
>> I just tried to install libgda 1.3 on a Fedora Core 3 machine, updated
>> with the development libraries and got the following.
>> Using config source xml::/etc/gconf/gconf.xml.defaults for schema
>> installation
>> Using $(sysconfdir)/gconf/schemas as install directory for schema files
>> checking for pkg-config... /usr/bin/pkg-config
>> checking for gtk+-2.0 >= 2.6.0 libgda >= 1.3.0... Requested 'gtk+-2.0 >=
>> 2.6.0' but version of GTK+ is 2.4.14
>> configure: error: Library requirements (gtk+-2.0 >= 2.6.0 libgda >=
>> 1.3.0)
>> not m et; consider adjusting the PKG_CONFIG_PATH environment variable if
>> your librarie s are in a nonstandard prefix so pkg-config can find them.
>> If I upgrade gtk from source will affect anything else on the system?
>> Or is it some other problem.
> You are probably referring to libgnomedb rather than libgda. The new
> requirement for libgnomedb (according Vivien's message a couple of days
> ago) is now Gtk+ >= 2.6 (because of the GtkComboBox widget). I run FC3
> as well and the "default" GTK+ is 2.4.x, so yes you should upgrade GTK+
> to 2.6.x. I am not using libgnomedb at the moment, so can not advise you
> of any FC3 specific steps to take, but I assume you can get all the info
> you need at
> Bas.

yes that correct libgda went ok libgnomedb was where I had the problem.
I have some spare hard drive space so I will did an install there an play
around with it.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]