[gnome-db] Timestamps in mergeant and encoding of strings

Hi all!

Trying to insert data in a table that has a timestamp column (postgres) i
got into some troubles.

First is that the date is MM-DD-YYYY format and the providers sets ISO
date format on startup (YYYY-MM-DD). After changing the format to be an
ISO date, i tried to insert a new value and i got a warning and then 
mergeant crashed.

The warning says that the value is not a timestamp. Indeed. The value is
a string containing something like: "\timestamp('now'::date)".

I tried to figure out what's happening, but i couldn't and now it's time
to sleep ;-).

Any hint?

Also strings are not displayed correctly if they contain non-ASCII
characters. I have filled a bug about it suggesting a new function that
the providers must implement to either tell the users of libgda what's
the encoding for strings in the backend or translates all the strings
to/from UTF8.



Gonzalo Paniagua Javier <gonzalo gnome-db org>

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]