Re: request change at GDA_Report.idl

El 07 Jan 2001 14:13:26 +0100, Rodrigo Moya escribió:
> >       typedef sequence<octet> Chunk;
> >       interface ReportStream {
> >               Chunk readChunk (in long start, in long size);
> >               long writeChunk (in Chunk data, in long size);
> >               long getLength ();
> >       };
> > </new>
> > 
> > If we don't change this we have at the implementation code a variable
> > like: GDA_ReportStream_ReportStreamChunk and IMO, this kind of variables
> > aren't good.
> > 
> yes, you're maybe right. But, in fact, what should be changed are all the IDL

Rodrigo, excuse me , but it's all ok, when i was reading the IDL i
thought that ReportStreamChunk was inside the ReportStream interface but
that is incorrect, so I think that all is correct and we don't need to
modify the IDLs.

> interface names, since they're all like Report..., and the
> CORBA-generated functions are GDA_Report_Report..., when they should be
> GDA_Report_..... So, yes, if you want to change it, do it, but please do
> it for all interfaces.
> cheers

Carlos Perelló Marín
mailto:carlos gnome-db org
mailto:carlos hispalinux es
Valencia - España

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]