Re: request change at GDA_Report.idl

>       typedef sequence<octet> Chunk;
>       interface ReportStream {
>               Chunk readChunk (in long start, in long size);
>               long writeChunk (in Chunk data, in long size);
>               long getLength ();
>       };
> </new>
> If we don't change this we have at the implementation code a variable
> like: GDA_ReportStream_ReportStreamChunk and IMO, this kind of variables
> aren't good.
yes, you're maybe right. But, in fact, what should be changed are all the IDL

interface names, since they're all like Report..., and the
CORBA-generated functions are GDA_Report_Report..., when they should be
GDA_Report_..... So, yes, if you want to change it, do it, but please do
it for all interfaces.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]