Re: problems with RPMs

> > > Ok, so I change the name to gda-odbc, and I get this error:
> > > 
> > sorry, I hit the send button too quick. The error I get is:
> > 
> > + STATUS=0
> > + [ 0 -ne 0 ]
> > + cd gda-odbc-0.1.0
> > /var/tmp/rpm-tmp.73828: gda-odbc-0.1.0: No such file or directory
> > Bad exit status from /var/tmp/rpm-tmp.73828 (%prep)
> > 
> It sounds like if you have change the PACKAGE for gda-odbc if you have
> do so, then you must change your
> BuildRoot: instead of something
> like:  /var/tmp/%{PACKAGE}-%{PACKAGE_VERSION} to
> /var/tmp/libgda-%{PACKAGE_VERSION}
> If you don't understand me, please tell me and i will write you a
> spanish answer.
> If this does not resolve your problem, please, send me the .spec
> modified.
ok, I've done what you suggested,that is, I changed the BuildRoot, but I
still get the same error, so here's the spec file.

# Note that this is NOT a relocatable package
# defaults for redhat
%define name	gda-odbc
%define ver	@VERSION@
%define prefix     /usr
%define sysconfdir /etc

%define  RELEASE 1

Summary: GDA ODBC
Name: 		%name
Version:	%ver
Release: 	%rel
Copyright: 	GPL
Group: 		Applications/Databases
BuildRoot: 	/var/tmp/libgda-%{ver}-root
DocDir: 	%{prefix}/doc

GNU Data Access is an attempt to provide uniform access to
different kinds of data sources (databases, information
servers, mail spools, etc).
It is a complete architecture that provides all you need to
access your data.

libgda was part of the GNOME-DB project
(, but has been
separated from it to allow non-GNOME applications to be
developed based on it.

This package contains the ODBC provider.

* Sat Sep 2 2000 Rodrigo Moya <rodrigo linuxave net>
- Initial spec imported from old GNOME-DB spec



# libtool workaround for alphalinux
%ifarch alpha

# Needed for snapshot releases.
if [ ! -f configure ]; then
  CFLAGS="$RPM_OPT_FLAGS" ./ $ARCH_FLAGS --prefix=%{prefix} --sysconfdir=%{sysconfdir} --with-odbc=/opt/unixodbc
  CFLAGS="$RPM_OPT_FLAGS" ./configure $ARCH_FLAGS --prefix=%{prefix} --sysconfdir=%{sysconfdir} --with-odbc=/opt/unixodbc

if [ "$SMP" != "" ]; then
  (make "MAKE=make -k -j $SMP"; exit 0)


make prefix=$RPM_BUILD_ROOT%{prefix} sysconfdir=$RPM_BUILD_ROOT%{sysconfdir} \
oafinfodir=$RPM_BUILD_ROOT%{prefix}/share/oaf \


if ! grep %{prefix}/lib /etc/ > /dev/null ; then
  echo "%{prefix}/lib" >> /etc/
%defattr(-, root, root)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]