Splitting GUI and non-GUI parts of bonobo



I would like to split the GUI and non-GUI parts of Bonobo into two
separate libraries. For various projects people would like to (or
should) write interfaces that inherit from Bonobo::Unknown but that
are for non-gui services that should not have an X dependency.

The non-GUI part will include at least Bonobo::Unknown and perhaps
some of the other interfaces that are not X-dependant (maybe all). It
will require only a gtk_type_init() and not a gtk_init() call.

I propose libbonobo as the name for the non-GUI lib, and
libbonobo-control as the name for the GUI one. The namespace will
still be "bonobo_" for both.

This will work even better with Gtk+ and Glib 1.4, where the type
system will be in glib and not gtk+, but I think starting now is a
good idea; then the API will break less in the future. To preserve
history properly, this needs to be done at least partly by moving
files on the CVS server, so I am not sending a patch.

I will send a proposal for what files from the bonobo/ directory I
think belong in which library.

Actually, if people really want, I can do this without CVS magic just
by hacking the Makefile.am in the bonobo/ directory to build two
separate libs, but I think splitting the directories is better
long-term.

 - Maciej




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]