gobject-introspection 0.9.6



Hi,

GObject Introspection 0.9.6 is now available:

http://ftp.acc.umu.se/pub/GNOME/sources/gobject-introspection/0.9/

This is another unstable release as we close in on the GTK 3 schedule, fixing
some bugs necessary for 2.32.

Notably that this release re-adds the --strip-prefix option, enabling
builds under
both 0.9.3 and 0.9.6; however it's treated equivalently to --identifier-prefix,
meaning that capitalization matters.

Because I didn't attach the shortlog to 0.9.5, here it is since 0.9.3
(last release):

Alan Knowles (1):
      Enhancement #612253 - add configure --with-glib-src=PATH

Colin Walters (81):
      Remove --noclosure argument
      gir: Drop warn-all from GLib
      Remove tests/invoke
      compiler: Remove --code argument
      gir: Import DBus, DBusGLib
      [girparser] Cleanly pass through c:include
      [girepository] Fix up error printing
      [gircompiler] Clean up parsing
      scanner: If GI_SCANNER_DEBUG is set, drop into a debugger on error
      .gitignore: Update
      gobject-introspection-1.0.pc: Export datadir
      tests: Remove GIMarshallingTests, rename Everything to Regress
      tests: Fix namespacing for BarApp (should be just Bar)
      Move alias target to <type>
      Use GLib types consistently
      tests/scanner: Update annotations and tests
      pep8: Update to 99 length lines
      Major rewrite
      tests: Readd gimarshallingtests.[ch]
      tests: A few fixes for building
      gimarshallingtests: Fix (inout) test cases, drop unsupported API
      major: Fix parent for GInitiallyUnowned
      scanner: Avoid internal invalid Type instances from parents
      scanner: Better handling of empty namespace prefix for X
      scanner: Add a hack for AtkAttributeSet
      scanner: Filter interface prerequisites and class implements for
unknown types
      makefile: Fix name of maintransformer
      configure: Bump version to 0.9.5
      scanner: Avoid infinite loop in constructor check
      scanner: Add --accept-unprefixed
      scanner: Refactor name parsing
      scanner: Cosmetic cleanup to namespace parsing functions
      scanner: Don't parse constructors on non-registered, warn for
return values
      tests: Move FooSkippable to public headers to test comments in headers
      scanner: Skipped nodes aren't introspectable either
      girepository: Fix compatibility typedefs
      scanner: Better handling of GType names
      scanner: Also look for enums and bitfields with GType names
      scanner: Don't throw an exception on unresolved types
      scanner: Add --include-uninstalled
      scanner: Associate constructors with correct class
      girepository: Call init_globals()
      scanner: Actually exit with code 1 on fatal warnings again
      scanner: Readd --warn-error to tests, fix test case
      scanner: Fix misuse of message.warn_symbol
      scanner: Fix rename-to handling
      scanner: Fix previous rename-to handling commit
      scanner: Don't clear out ctype on annotation strings if we fail to resolve
      scanner: Add backwards compatibility with some annotation types
      scanner: Add various static debug hooks in GI_SCANNER_DEBUG
      scanner: Fall back to searching all includes when uncertain
      tests: Update expected gir for previous commits
      scanner: Automatically skip callables which contain a skipped node
      scanner: Don't attempt to pair methods/constructors with foreign
namespaces
      scanner: Fix object hierarchy traversal in constructor scanning
      scanner: Don't mark as constructors things that are more obviously methods
      scanner: Kill glibast
      gio: annotate g_mount_get_volume
      scanner: Fix style for previous commit
      scanner: Unify parsing of compounds
      gio: Annotate g_mount_get_drive
      gio: Annotate a few more functions
      scanner: Mark '_'-prefixed fields as introspectable=0
      scanner: Skip functions with leading '_'
      gio: annotate g_volume_get_drive
      build: Update EXTRA_DIST, fix random stray + in Makefile
      build: Use $DESTDIR in install-data-local
      build: Also use $DESTDIR for regress.[ch]
      scanner: Allow gstreamer's GParamSpecMiniObject through
      scanner: Readd support for --strip-prefix
      scanner: Bomb out more obviously if a namespace contains class
name = namespace
      scanner: Add GType for GVariant
      scanner: Add a test for G_TYPE_ARRAY and (element-type uint)
      scanner: Consistently use ctype for documentation blocks
      scanner: Handle G_TYPE_HASH_TABLE
      scanner: Parse annotations for typedefs
      typelib compiler: Passthrough <doc> at any point
      tests: Don't build regress if we don't HAVE_CAIRO
      scanner: Add c_type for callbacks
      scanner: Add temporary workaround for GStreamer
      Release 0.9.6

Florian Müllner (1):
      Add missing annotations

Funda Wang (1):
      [tests] Link libfoo against girepository

Gustavo Noronha Silva (1):
      [scanner] Also parse C++ files

Joe Marcus Clarke (1):
      [girepository] Support strict align platforms

Johan Dahlin (66):
      [everything] Remove allow-none for Return value
      [man] Mention XDG_DATA_DIRS
      Delete trailing whitespace
      Add a pre-commit hook and enforce it
      Add pre-commit to EXTRA_DIST
      [girepository] Add a couple of missing transfer
      [GIRepository] Rename GArgument to GIArgument
      [GIRepository] Rename GTypelib to GITypelib
      [GIRepository] Add missing transfer and skip
      [scannermain] Sort imports alphabetically
      [scannermain] Add - as an alias for stdout
      [scannermain] Write to tempdir if needed
      [scannermain] Use shutil.move instead of os.rename
      [scannermain] Use return instead of sys.exit()
      [scannermain] Simplify writing of output data
      [scannermain] Use _error() consistently
      [scannermain] Hide a couple of private options
      [scanner] Remove support for xpath assertions
      [scanner] Create the cachestore in the transformer
      [annotationparser] Send in comments directly
      [transformer] Don't pass around source scanner
      [scanner] Move namespace out of Transformer
      [scanner] Allow nameless parameters for vfuncs
      [scanner] add a message module
      [scanner] Simplify strip_identifer/strip_symbol
      [scanner] Move over remaining callsites to message
      [scanner] Remove old logging functions
      [message] Add an output parameter
      [scannermain] Create a new option parser
      [message] exit after calling message.fatal()
      [scanner] Improve an error message, include lineno
      [tests] Add test infrastructure for warnings
      [tests] Rework tester to be executed once per test
      [tests] Add callback scope tests
      [giscanner] Make pyflakes happy
      [scannermain] Use mkstemp
      [tests] Handle multiple errors per file better
      [test] Add warning tests for enums
      [scanner] Move a function from transformer to ast
      Remove old everything.[ch]
      Update CONTRIBUTORS
      [scanner] Remove a bunch of unused functions
      [pep8] Skip emacs backup files
      [scanner] Clarify exception message
      [scanner] Revert static method pairing
      Revert "Fix non-source-dir build failure"
      [scanner] Make it compatible with Python 2.5 again
      [scanner] Fundamental problems are not fatal
      [scanner] Make fatal warnings exit
      Revert "[scanner] Revert static method pairing"
      [girepository] Add a missing include
      [tests] Remove left over variable
      [tests] Add  to EXTRA_DIST
      Do not require .git to be present
      Do not use install-data-local
      [test] Use INTROSPECTION_SCANNER
      [test] Add typelib/girs to CLEANFILES
      [test] Fix a leftover rename
      Add a few notes to HACKING
      [warningtester] Invert expected/actual
      [warningtester] Do not sort expected warnings
      [gio] Fix a broken doc string
      Add a parameter mismatch warning
      NEWS->git shortlog
      Add a warning for unresolved types
      [maintransformer] Do not warn for vararg docs

John (J5) Palmieri (1):
      trick scanner into marking a symbol as a function instead of a method

Luca Bruno (1):
      Makefile.introspection: Add _EXPORT_PACKAGES variable.

Matthias Clasen (2):
      Add Colormap stub
      Add a stub entry for XLib Visual

Maxim Ermilov (1):
      add annotation for g_get_language_names

Owen W. Taylor (4):
      Go back to previously handling of static methods on non-GObjects
      Add missing annotations to GLib and Gio
      Handle casing better for constants
      gio-2.0.c: Add more annotations for GVolume and GVolumeMonitor

Pavel Holejsovsky (3):
      [girepository] Document GIStructInfo & GIUnionInfo
      Box GIBaseInfo structure.
      Update annotations for GIRepository.Repository.

Philip Withnall (1):
      Bug 628594 — Handle slashes when building _gir_name

Robert Ancell (1):
      Fix giscanner crash with no cache directory

Ryan Lortie (1):
      Bump the version after releasing 0.9.3

Saikiran Madugula (1):
      Print helpful error message if --strip-prefix option is used.

Simón Pena (1):
      gio-2.0.c: Add missing annotations

Steve Frécinaux (3):
      Include the loaded version in g_irepository_enumerate_versions()
      Fix warning when using g_irepository_enumerate_version()
      [VFuncBlob] Unknown struct offset should be 0xFFFF

Theppitak Karoonboonyanan (1):
      Fix non-source-dir build failure

Tomeu Vizoso (10):
      Add g_i_marshalling_tests_gvalue_in_enum
      Update gir/GIMarshallingTests-1.0-expected.gir
      Remove uncommitted function from gir/GIMarshallingTests-1.0-expected.gir
      Add properties to Everything.TestObj for testing more types
      Fix typo (reported by philn-tp)
      Remove extra lines from the license comment
      Use Node.ctype instead of Node.c_name when looking up comment blocks
      Foreign structs can have constructors
      Add annotation for g_variant_get_string
      Annotate g_variant_builder_end

Zachary Goldberg (1):
      Add ability to write unindented lines via xmlwriter


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]