[ANNOUNCE] libchamplain 0.5.2

Hello everyone,

it has been a long time since the last 0.5.x release at the end of
January. There have been many changes since then in the libchamplain
development. One of them is the change of the libchamplain maintainer
- the maintainership has been passed to me by Pierre-Luc. Many thanks
to him for the great idea to create this library and bring it to life!
I'll do my best to continue in his work.

So what has changed since the last release? Here is the summary:

* Different tile reference management eliminating tile leaks
  (Jiří Techet)
* General performance improvements (Jiří Techet)
* Tile download cancellation when tile not displayed any more
  (Jiří Techet)
* Build process improvements, libmemphis dependency made optional,
  documentation updates (Jiří Techet)
* Removal of unmaintained mono bindings, removal of perl bindings
  (will be distributed separately)
* Updated python bindings (Victor Godoy Poluceno)
* New demo using introspection written in javascript (Simon Wenner)
* Many bugfixes and cleanups - for details see ChangeLog
  (Pierre-Luc Beaudoin, Jiří Techet, Emmanuel Rodriguez, Rob Bradford,
   Fridrich Štrba, Simon Wenner, Brian Cameron, Lorenzo Masini)

(Sorry if I have overlooked someone's commit in the git history. Run
'git log' if you don't want to rely on my bad summarizing abilities.)

Get it here:


I think everyone has noticed that we are pretty much behind the gnome
release schedule - this is why I'd like to release libchamplain 0.6 as
soon as possible. If there are no show stoppers, this could happen the
following weekend. I'm pretty happy about the stability of this
release; that said, don't hesitate to make me unhappy if you encounter
any bugs - better to get them reported now than after the stable
release. So if you encounter problems of any kind (build issues,
strange console warnings, stability issues, API functions not working
correctly, bindings problems), please report them to libchamplain's
bugzilla. There is currently one bug that worries me a bit:


The problem is that I'm not able to reproduce it so I'm not sure if
it's caused by some strange linux setup or if it is a more widespread
problem. Please add a "me too" comment to the bug if you experience it
as well.

There are also some platforms that are not available to me (I'm
talking mainly about maemo here) so it would be great if anyone
running an exotic environment could test it there.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]