Re: Follow-up

I can't reproduce exactly the bugs you're having, but mine are similar. First, I can't get the keypad to work correctly. There's no problem switching layers, but 
as soon as I try to use a command on the chosen layer, gnopernicus acts as though focus has changed. I hear "switch to window" and then the title of the 
current window. Of course, focus hasn't changed at all, but gnopernicus thinks it has. This is especially problematic for the use of flat review, as it doesn't 
stay active for more than about a second before switching back to focus tracking. I really wish there was a way to lock flat review on. Interestingly, when 
using keys on my powerbraille 80 which are mapped to certain functions, gnopernicus doesn't seem to have the focus problem. It seems to only happen 
when the commands are initiated from the keyboard. This bug started when I updated my gnopernicus CVS about 2 weeks ago and is still present.
The second bug I'm having causes a lock-up. I don't know when it's going to happen, but it's always after attempting to use flat review. The system locks 
up so bad that the only thing I can do is a hard reset, even ctrl+alt+del doesn't work. I didn't think that anything could totally freeze a linux system like that, 
but gnopernicus does it, somehow. My system specs are:
amd athlon xp2600 2.133ghz running slackware 9.1, gnome 2.4.0 and gnopernicus CVS. I use the brlapi driver for braille as well as the dectalk software for 
speech output.

On Sat, 27 Sep 2003 12:56:44 -0500, Nolan J. Darilek wrote:

>A few days ago I posted about some rather odd and crippling bugs in
>gnopernicus. Haven't received any responses, so I'm assuming that
>nobody else can duplicate them.
>To recap: I'm consistently reproducing two bugs. First, I can switch
>layers, but I don't get the typical "Layer n" feedback; instead, the
>last utterance is repeated. Additional information: Layer feedback
>works fine, but it seems to fail when I instantiate my first
>non-gnopernicus application. As soon as emacs/emacspeak or GAIM pops
>up (dunno if all applications are at fault, but these are the two I've
>tried) the behavior begins.
>Second, going into flat review mode locks up my system. Additional
>testing reveals that this isn't a system lockup, but only seems to
>effect X. Regardless, however, I can't shut down X, switch to another
>console, and the only remedies are either a hard reboot or logging in
>from my powerbook and running a shutdown from the console.
>I realize that these are elusive bugs that others aren't likely to
>duplicate. If it would help, I'm willing to set up a test account on
>my box and grant anyone willing to help track this down access. As
>this setup has worked fine for months, and the only changes made were
>a) adding --disable-magnifyer to the gnopernicus command line a week
>or so back (it started hanging, waiting for a connection to the
>magnifyer which I don't use) and b) various system updates, I'm
>leaning toward it being a bug in the latest CVS checkout, though I
>suppose it's also possible that I broke something and just haven't
>caught it yet.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]