RE: FreeTTS with Gnome-Speech Question

I was told (by whom, I forget) that the problem has to do with support
for mono 16 bit versus stereo; the newer sound drivers apparently don't
support 16bit mono.  Apparently the mono stream from festival is getting
split over two channels somehow, which has the effect that each channel
gets every other sample, thus doubling the speed.  

There's a workaround for this that basically takes the mono 16bit output
and converts it to stereo on-the-fly (just by duplicating the samples)
but I can't remember who told me about it, nor how to do it.

I believe that there should be a way to configure festival to send
stereo output, which would be another solution.

Does someone on this know more about this, for instance how to
reconfigure festival in this way?  I suppose one possibly useful
consequence of this is that festival voices could be configured to come
out of one stereo channel of the other, which might have some utility. 
(Perhaps gnome-speech could export this channel-fade behavior as one of
its properties, for speech engines that support it.)


On Tue, 2003-03-25 at 23:30, Bue Vester-Andersen wrote:
> Hi Janina,
> I have experienced Festival behaving exactly that way with redhat 8.0. and
> an integrated ac97 sound card in an IBM Netvista. I suppose it is something
> to do with the sound driver or the communication between festival and the
> driver.
> But your question kind of answers mine. I think I will try and install
> Phoebe tomorrow with sighted assistance and then patch with speakup to get
> running in text mode. Did you just get gnopernicus and compile streight away
> with phoebe or did you also have to get other external packets as well?
> Regards
> Bue
> -----Original Message-----
> From: gnome-accessibility-list-admin gnome org
> [mailto:gnome-accessibility-list-admin gnome org]On Behalf Of Janina
> Sajka
> Sent: Tuesday, March 25, 2003 7:58 PM
> To: gnome-accessibility-list gnome org
> Subject: FreeTTS with Gnome-Speech Question
> I'm tryhing to get Gnopernicus working again. The compiles appear to have
> gone without a hitch using the latest Red Hat
> betas, named Phoebe. And, Gnopernicus launches just fine.
> My problem is that I get Mickey Mouse from Festival, which is the only
> speech test-speech seems to be able to find.
> I have tried both the Red Hat supplied Festival-1.4.2, and a compile of the
> February release of Festival-1.4.3. Same
> story, speech appears to come at 4-times speed (or even greater).
> I get the same undesirable effect from ViaVoice 5.1, which I have only as
> binaries, of course.
> Strangely, Festival Lite, which I compiled afresh, as there's now a 1.2
> release, works fine.
> I have also obtained the j2sdk-1.4.1_02 from, and have compiled
> FreeTTS from cvs today. FreeTTS talks
> appropriately when I launch either the freetts (client) or frettsServer
> scripts. However, test-speech doesn't seem to
> see FreeTTS.
> Am I starting them correctly? I cd to the directory containing these scripts
> and issue ./[] as root. Should I
> do this differently?
> NOTE: If, instead, i run the jar script, I get:
> ./jarfreetts
> Exception in thread "main" java.lang.NoClassDefFoundError:
> com/sun/speech/freetts/FreeTTS
> Can I use FreeTTS with gnome-speech? How should I start and test?
> Thanks for any help.
> --
> 				Janina Sajka, Director
> 				Technology Research and Development
> 				Governmental Relations Group
> 				American Foundation for the Blind (AFB)
> Email: janina afb net		Phone: (202) 408-8175
> _______________________________________________
> gnome-accessibility-list mailing list
> gnome-accessibility-list gnome org
> _______________________________________________
> gnome-accessibility-list mailing list
> gnome-accessibility-list gnome org
Bill Haneman <bill haneman sun com>

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]