Re: Compile errors (was Re: Accessibility of Gnome panel / How toend session via keyboard)

>> > What exact steps did you go through to get here? The information I am
>> 1) Downloaded the source tar balls from
>> 2) Untarred the source.
>> 3) hacked around to get the .configure to work.
>> a) IE installed a couple of packages that were missing
>> b) Had to manually create dummy .pc files because for some reason my
distro didn't have the pc files. (maybe this is the cause?)

>This is certainly a bit suspect -- mostly because there is no way for
>you to really know what should go into the pkg-config files. The .pc
>files should come with the *-devel.rpm files for each of the packages
>concerned. If you don't have a particular .pc file, then you are missing
>a package. Mandrake is very good about packaging the right files, so you
>should probably undo this step and try to find the right packages.

That's just it... With Mandrake Linux 9.1; they didn't include -devel RPMs
or Source RPMs on the three ISOs I downloaded.
I'm probably missing something; but I looked on all three CDs and couldn't
find anything that looked like it had the sources on it. Which is
surprising; because I'm sure Mandrake is required to distribute the sources
as part of the CD per GPL licensing. I figure it's just a simple; "the
sources are here" pointer.

I spent 2 frustrating days trying to locate the source; before I gave up and
downloaded the source from I searched various RPMs... tried doing
google searches for a how-to newbie type guide to compiling gnome from
mandrake cds... but came up empty.

>If you can remember which files you needed to create, we can probably
>work out what packages you need.

Almost all of them. Here's a list of *.pc files I manually created:

-rw-r--r--    1 root     root          184 Jul  2 07:34 libbonoboui-2.0.pc
-rw-r--r--    1 root     root          178 Jul  2 07:32 libglade-2.0.pc
-rw-r--r--    1 root     root          197 Jul  2 07:30
-rw-r--r--    1 root     root          183 Jul  2 07:29 gnome-vfs-2.0.pc
-rw-r--r--    1 root     root          190 Jul  2 07:27 gnome-desktop-2.0.pc
-rw-r--r--    1 root     root          178 Jul  2 07:25 libwnck-1.0.pc
-rw-r--r--    1 root     root          182 Jul  2 07:23 libgnomeui-2.0.pc
-rw-r--r--    1 root     root          180 Jul  2 07:21 libgnome-2.0.pc
-rw-r--r--    1 root     root          173 Jul  2 07:16 gtk+-2.0.pc
-rw-r--r--    1 root     root          216 Jul  2 07:13 gdk-pixbuf-2.0.pc
-rw-r--r--    1 root     root          249 Jul  2 06:57 ORBit-2.0.pc

>> 4) ./configure ran with no errors.
>> 5) did a make.
>> > after is things like what source files are you using for gnome-panel
>> > (tarballs? If so, what release number? CVS version?). Do you have the
>> > rest of GNOME compiled from source, or are you using your
>> > distribution's
>> > installation? What distribution are you using?
>> I haven't tried compiling the rest of the source... just gnome panel
>> I tried downloading the distributions source with the same results.
>> Mandrake Linux 9.1 is my distribution of choice.
>Generally a very safe choice for building GNOME stuff. Mandrake's GNOME
>maintainer (Frederic Crozat) is very knowledgeable.

For whatever reason; this version of MLinux9.1 is not as friendly as past
versions... at least I haven't been able to locate the sources like I
expected I would be able to do.
I guess in the past; I've just downloaded the files from the internet (like
postfix, bind9, ect) and compiled them with no issues. Kernel compiling also
came easy for me. But Gnome seems to be more difficult or maybe I'm just
missing something simple. It's probably just "user error".


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]