[Glade-users] Cannot open old *.glade files

Hi all,
I have a problem with an old GTK UI. I want to open and view the
coresponding *.glade files in Glade. When I try to open one of them with
the current Glade (3.20) I get an error, that the UI was made for
GTK+2.16 and thus cannot be opened with Glade 3.20 (which of course
makes sense to me) and that I should first make sure that it can be
opened with Glade 3.8).

So, I installed Ubuntu 12.04 in a VM and installed Glade 3.8. There, I
tried to open one of the *.glade files with Glade-GTK2 and again got an
error, saying something like "file [myfile] could not be saved because
catalog xyz could not be loaded". The catalog files (XML files with the
root tag <glad-catalog>) are in the same directory as the *.glade files.
In the documentation
(https://developer.gnome.org/gladeui/stable/catalogintro.html) I read
that, in order to work with catalogs, the variable
GLADE_CATALOG_SEARCH_PATH needs to be added to the environment and set
to the correct path. I did that, but got the same error message.

Any idea how I can open the *.glade files?


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <https://mail.gnome.org/archives/glade-users/attachments/20170820/837a8dad/attachment.sig>

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]