[Glade-users] Gtk-CRITICAL from minimal program.

I'm using Glade 3.4.5 on a Fedora 9 x86_64 system and I have started to learn Anjuta IDE to work on a Glade3 
project. I started by making a minimal program consisting of just one main Gtk window to get the hang of 
things. When I run this program I get this error:

Gtk-CRITICAL **: gtk_widget_show: assertion `GTK_IS_WIDGET (widget)' failed

To try to isolate the problem I made essentially the same program in Glade 3 and I get the same error 
message. Is this a know problem? I didn't see it on the bug list.
It could be a glade problem not - writing the .glade file correctly, a converter problem - not generating the 
.xml file correctly or a parser problem -  not reading the .xml file correctly... or it could just be me.

I have attached my minimal .glade file and main.c file

I followed Micah Carrick's tutorial at http://www.micahcarrick.com/01-01-2008/gtk-glade-tutorial-part-3.html 
to convert the .glade file to a .xml file

$ gtk-builder-convert glade_test.glade glade_test.xml

used his minimal program and compiled the it with this line:

$ gcc -Wall -o junk main.c `pkg-config --cflags --libs gtk+-2.0`


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]