[Fwd: Re: [Glade-users] Problems compiling glade-- project]

Problem solved now. The gtk/ and gdk/ library directories as well as the
glib.h file were not in their correct locations. Strangely enough, since I
haven't touched any of them since install. So, either the gtk1.2 and glib1.2
don't end up in the correct locations on install, or gdk-- and whatever else
is using them are wrong about where they ought to be. Anyone else
experienced this problem? It was easy enough to remedy, just made a few
symlinks, but still. It seems to me that every other time you try to compile
something (my system is a Red Hat linux 7.1 btw, and I haven't tampered with
it, honestly) you end up having to fiddle with the system in one way or the
other. Thought I'd be safe just having reinstalled the system from scratch,
but noo...

Anyway, thanks once more for the swift and accurate help.

-----Original Message-----
From: Emil Malmberg [mailto:emil iconmedialab dk]
Sent: 6. september 2001 09:45
To: jbrite
Cc: glade
Subject: Re: [Fwd: Re: [Glade-users] Problems compiling glade-- project]

Thanks a lot, that seemed to do the trick. Now autogen.sh works alright, but
when I type 'make' afterwards, I get a bunch of complaints about missing
files. Guess I have to check that I have all necessary libraries installed
the right places).

Thanks again / Emil

On Thu, 6 Sep 2001, jbrite wrote:

I think I know what the problem is/was.  If you are still instested.  If
you run ./autogen.sh to make the file then you change the GETTEXT
option, it will always have that error.  You need to delete every thing
in that projects dir except for the .glade file and the /src dir and
tell glade to save and build again.  Then rerun ./autogen.sh, then make
and then run the program.

I reremembered that I had to do this when I was helping someone else and
they had the gettext on and thought about your problem.

hope that helps,



If you haven't giving up all hope...

in the original post about the problem you had included the error
message, which mentioned the gettext was unavailible.

aclocal: configure.in: 29: macro `AM_GNOME_GETTEXT' not found in library

what's it saying now?


Emil Malmberg wrote:

I've tried disabling Gettext support, but it still doesn't work.
Thanks anyway for the tip, and if I get it working I'll let you know what
the problem :)


Glade-users maillist  -  Glade-users ximian com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]