[Glade-users] Problems compiling glade-- project

I've tried disabling Gettext support, but it still doesn't work.
Thanks anyway for the tip, and if I get it working I'll let you know what was
the problem :)


On Thu, 23 Aug 2001, jbrite wrote:

I get the same error, I think this happends on some systems, but I don't
know why.  One of the GTK+ books a have has a glade tutor and they claim
it's a bug.  The way I handle it is by opening the opinions in Glade.
 There is a tab called 'C Options', disable Gettext Support.  Save and
build, then run that ./autogen

hope that helps, by the way I'm running Glade 0.5.11


Emil Malmberg wrote:


I'm just trying out glade and created a very basic user interface
consisting of a window with a couple of labels, buttons, textboxes and
radio buttons. Pressing "build" to produce the C++ output works fine, but
when I run autogen.sh it grinds to a halt. This is what happens:

dkcphw101% ./autogen.sh
**Warning**: I am going to run `configure' with no arguments.
If you wish to pass any to it, please specify them on the
`./autogen.sh' command line.

processing .
deletefiles is
Creating ./aclocal.m4 ...
Running gettextize...  Ignore non-fatal messages.
You should update your own `aclocal.m4' by adding the necessary
macro packages gettext.m4, lcmessage.m4 and progtest.m4 from
the directory `/usr/share/aclocal'
Making ./aclocal.m4 writable ...
Running libtoolize...
You should add the contents of `/usr/share/aclocal/libtool.m4' to `aclocal.m4'.
Running aclocal  -I macros ...
aclocal: configure.in: 29: macro `AM_GNOME_GETTEXT' not found in library
Running autoheader...
Running automake --gnu  ...
macros/Makefile.am:33: INSIDE_GNOME_COMMON does not appear in AM_CONDITIONAL
Running autoconf ...
Running ./configure --enable-maintainer-mode --enable-compile-warnings ...
loading cache ./config.cache
./configure: line 524: syntax error near unexpected token `AM_INIT_AUTOMAKE(project1,'
./configure: line 524: `AM_INIT_AUTOMAKE(project1, 0.0)'

In the FAQ, there is something about the first problem (macro 'AM_GNOME_GETTEXT' not found...), and it 
says to add an env. variable with the path to aclocal, but when I do, the problem persists and I get lots 
of messages saying things are defined twice etc.

Also, there is nothing in the FAQ about the last problem (the syntax error in line 524).

Does anyone know anything about this? I'd sure appreciate some help.
Thanks a lot / Emil

Emil Malmberg
Programmer, Icon Medialab Denmark

emil iconmedialab dk
+45 22651393 / +45 33320209 (fax)

Glade-users maillist  -  Glade-users ximian com

Glade-users maillist  -  Glade-users ximian com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]