[Glade-devel] How glade should name new widgets

On Fri, Mar 31, 2017 at 4:54 AM, Tristan Van Berkom
<tristan at upstairslabs.com> wrote:
Rather, is there a reason I'm missing why one would desire to have the
project full of names, now that this is no longer a requirement ?

Integration with IDE's. If you try the latest glade version with
anjuta and drag-and-drops a signal on the source code (to create a
callback), the widget will come with the strange name __glade_unnamed;
this is strange and unintuitive. The same should happen if the user
double-clicks a widget on the inspector. It is very important for
widgets to have ID's set so that the automatic callback/member
generation will work correctly.

I do agree that ok_button is a much better name than button1, but the
user still can change its ID anyway, so it will not be a bigger effort
than with the current behavior.

Do you have any idea on how to properly ensure that widgets have ID's
before automatic callback/member generation? Should this be handled by
the IDE or by glade? Should a warning be displayed if the user tries
to drag-and-drop a signal (or double-clicks a widget on the inspector)
if the widget has no ID? Should automatic callback/member generation
be forbidden for id-less widgets? What do other interface builders do?

We have to list our options and decide which is better. What do you
think should be the adequate behavior?

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]