[Glade-devel] Building Glade / error-message "attempting to create schema 'org.gtk.Settings.FileChooser' without a path"


I nevertheless invite you to try this binary on debian wheezy:

If it's 64bit linux then I'm pretty confident the binary will "just run"
it does run (more or less), so thanks for this.
Here's some feedback from using this version (3.16.0) to create a small GUI:


- It uses some weird theme, and looks completely different than all
  other GTK+-applications here (btw. I'm not using GNOME but plain fvwm).
  Maybe the message "GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved 
or shared with other applications."
  has something to do with this. Can this be changed, so that some
  default theme is used?

- It's again much slower than Glade 3.12.
  Selecting widgets is slower, and editing properties sometimes is
  extremely slow (see bug below).
  Maybe it's the weird theme that makes it generally slower, I don't know
  (and cannot test this, since I cannot find any way to modify the theme).

- The layout of the items in the properties-editor became *much* worse.
  In older versions, most properties used entries or toggle-buttons,
  and were all positioned vertially below each other.
  Now, many properties use switches (which I like) and checkboxes.
  This would be ok, but the layout got very messy: Some properties
  are positioned below each other, others horizonatlly next to each
  other, sometimes in 2 columns, sometimes in 3 columns.
  This makes the layout very messy, confusing and hard to use.
  In addition, this causes the properties-editor to require more
  space on the screen, sometimes nearly half (!) of the screen,
  to show the properties without a horziontal scrollbar (e.g.
  for GtkScrolledWindow).

  So, I would suggest to improve the layout, make it more clear and
  use a clear structure, e.g.: Put all properties vertically below
  each other instead of horizontally next to each other. This would
  improve usability a lot.

  (The Signals-tab requires even more space (mostly because the Detail-
  and Handler-column use much space although they are empty), but this
  is less problematic than with the other tabs.)

- In earlier versions, I could shift-click (or ctrl-click?) an item on
  the palette, an then place this widget multiple times. This was very
  useful if I had to place e.g. many buttons or labels, but it doesn't
  work anymore. Could this be added again?

- In addition to the above: If I click on a wiget on the palette, is
  there any way to abort this without placing the widget? I would
  suggest to make this possible by e.g. pressing ESC or the
  mouse-pointer-button on the toolbar.


- Glade hangs:
  Glade often hangs, when dragging a created GtkPaned/GtkScrolledWindow/etc.
  Glade then only shows a modal window (on all virtual desktops, see
  attachment), doesn't react anymore, and causes 100% CPU load.
  In these cases, I have to kill glade (or more exactly: kill

- Properties editor becomes extremely slow:
  The properties-editor becomes extremely slow after working with it for
  some time: When I want to edit the ID of a widget the contents
  of a label, I sometimes have to type blindly and wait for several
  seconds (e.g. 8s!), or wait for 1 second (with 100% CPU-load!) after
  every chacter until the characters appear in the properties-entry!
  Closing and reopening the Glade-file or restarting Glade usually
  "solves" this for a while.

- Add Parent is broken:
  "Add Parent" does not work anymore e.g. on GtkFrame, GtkAlignment,
  GtkGrid, GtkBox etc. For example, if I create a GtkFrame, add a
  GtkLabel, and then want to add a GtkBox as parent, this doesn't work
  but shows the error "Widgets of type Alignment need placeholders
  to add children." The same error occurs e.g. when trying to add a
  GtkBox as Parent of a GtkGrid, or a Viewport as Parent to a GtkGrid etc.
  This worked in Glade 3.12.

- Missing "GtkImage" in Palette -> Miscellaneous:
  In the Palette under "Miscellaneous", "GtkImage" is missing.

- Missing "label"-property in GtkLinkButton Properties:
  There is no way to modify the displayed contents of the linkbutton!
  The only show "button", and this cannot be changed in Glade.
  Workaround: Edit the GtkBuilder-XML-file directly.

- Wrong widget in GtkButton Properties -> General -> Add custom content:
  I think "[ ] Add custom content" should be a radio-button instead of
  a checkbutton, since it completely behaves like a radiobutton.

- GtkButton Images are not shown in Glade:
  If I create a button including an image, the image is hidden in
  Glade, unless I click "Always show image". But this property was
  introduced in GTK+3.6, and I'm creating a GUI for GTK+3.2, so
  I cannot use this property.
  Later, in the application (with GTK+ 3.4), the image is shown
  correctly, only Glade doesn't show them.

- "Select Named Icon" in GtkImage Properties does not find any icons:
  Selecting the image by "Icon Name" is broken: The "Select Named
  Icon" does not find any standard-icons. This worked fine in
  Glade 3.12.
  (Maybe the folling message has to do with this:
  "GladeUI-Message: Glade needs artwork; a default icon will be used for the following classes:
   GtkApplicationWindow needs an icon named 'widget-gtk-applicationwindow'")

- Duplicate widgets in Properties -> Common -> Widget Spacing -> Expand:
  "Horizontal" and "Vertical" here have both a checkbutton and a switch.
  One should be enough, and I would recommend to keep the switch but
  remove the checkbox.

- Preview snapshot sometimes doesn't work:
  When clicking "Preview snapshot", I sometimes get an empty window
  and the assertion:
  (glade-previewer:8587): Gtk-CRITICAL **: gtk_box_pack: assertion 'gtk_widget_get_parent (child) == NULL' 

- Assertions:
  I got several assertions. In my understanding, assertions should only
  be used for coding errors, and not for unexpected input.
  Here's a list of some assertions, I got:

  (glade:8214): GladeUI-CRITICAL **: glade_project_selection_clear: assertion 'GLADE_IS_PROJECT (project)' 
  (glade:13717): Gtk-CRITICAL **: gtk_status_icon_set_from_file: assertion 'filename != NULL' failed
  (glade:13717): Gtk-CRITICAL **: gtk_status_icon_set_from_stock: assertion 'stock_id != NULL' failed
  (glade:13717): Gtk-CRITICAL **: gtk_status_icon_set_from_icon_name: assertion 'icon_name != NULL' failed

Compilation of newer versions:

- It would be nice if there would be some easier way to compile newer
  Glade-versions incl. all dependencies, since it seems that Glade
  is quite buggy, but bugs are only fixed in the newest version,
  which again depends on the newest GTK+-libraries...


-------------- next part --------------
A non-text attachment was scrubbed...
Name: glade-hangs.png
Type: image/png
Size: 4194 bytes
Desc: not available
URL: <http://lists.ximian.com/pipermail/glade-devel/attachments/20140530/9d5aae3c/attachment.png>

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]