[Glade-devel] glade: populating table/list with headers

On Sun, Jan 15, 2012 at 6:42 AM, Tristan Van Berkom <tristanvb at openismus.com

This is a very well known GTK+ bug which was in fact fixed almost
two full months ago in GTK+ git master.

I don't know why but it seems most distributions of GTK+ still
have this bug (because I hear a lot about it), to track the progress
of this you can follow:

It seems the fix should be available in an upcoming 3.2 release
(as per Benjamin's (Company's) comment that the fix has been
backported to the 3.2 branch).

If you can't get your hands on a recent version of GTK+ that
contains the fix, I can give you a quick pointer on how
to hack around that with Glade sources:

 o cd ~/path/to/glade/sources/
 o grep -r gtk_grid_set_column_spacing .
 o grep -r gtk_grid_set_row_spacing
 o edit any of column/row spacing assigned to a GtkGrid
   in Glade, you can simply remove these lines or change
   the set value to '0'
 o recompile and install Glade

That will avoid the crash for the time being.

Sorry for the inconvenience.


Hi Tristan,

I have done the following: first I ran upate manager on Ubuntu to update all
my packages including gtklib but that did not fix the problem. So I
and installed the following:


So I open the glade file...


$ glade whm.glade
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"
GladeUI-Message: No displayable values for property
GladeUI-Message: No displayable values for property GtkTreeSelection::mode
GladeUI-Message: 14 missing displayable value for

(glade:11355): GladeUI-CRITICAL **: Unable to load module
'gtksourceview-3.0' from any search paths

(glade:11355): GladeUI-WARNING **: Failed to load external library

(glade:11355): GladeUI-WARNING **: We could not find the symbol

(glade:11355): GladeUI-WARNING **: Could not get the type from

(glade:11355): GladeUI-WARNING **: Failed to load the GType for

(glade:11355): GladeUI-WARNING **: Tried to include undefined widget class
'GtkSourceView' in a widget group
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"
GladeUI-Message: The DevHelp installed on your system is too old, devhelp
feature will be disabled.

(glade:11355): Gtk-CRITICAL **: gtk_cell_view_set_displayed_row: assertion
`GTK_IS_TREE_MODEL (cell_view->priv->model)' failed


I add the TreeView to my file. RIght click -> Edit... and get the following:

(glade:11355): Gtk-WARNING **: GtkContainerClass::add not implemented for

Gtk-ERROR **: GtkBox child GladeEditorTable minimum height: -4 < 0
Trace/breakpoint trap


Why am I getting this message when I have downloaded and installed all the
latest versions
of gtklib and glade?

I desperately need a way to add a table with headers to my glade file.

Thank you for your help,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ximian.com/pipermail/glade-devel/attachments/20120115/766a6a0c/attachment.html>

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]