[Glade-devel] opening glade2 file on ubuntu 11.10

Hi all,

To add to my email, how do I install glade 2 on Ubuntu 11.10?
I tried downloading the glade-2.12.2.tar.gz and got the following
output when I run configure:



checking for IceConnectionNumber in -lICE... yes
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for GLADE_GTK... configure: error: Package requirements
(libxml-2.0 >= 2.4.1 gtk+-2.0 >= 2.8.0) were not met:

No package 'libxml-2.0' found
No package 'gtk+-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GLADE_GTK_CFLAGS
and GLADE_GTK_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


Also, I'm not sure what the complaints are about, when I inspect my
/usr/lib directory I get:

$ ls /usr/lib/{*xml*,*gtk*}
/usr/lib/libcanberra-gtk3.so.0      /usr/lib/libgtk-3.so.0.200.0
/usr/lib/libcanberra-gtk3.so.0.1.8  /usr/lib/libgtkmm-2.4.so.1
/usr/lib/libcanberra-gtk.so.0       /usr/lib/libgtkmm-2.4.so.1.1.0
/usr/lib/libcanberra-gtk.so.0.1.8   /usr/lib/libgtkmm-3.0.so.1
/usr/lib/libdbusmenu-gtk3.so.4      /usr/lib/libgtkmm-3.0.so.1.1.0
/usr/lib/libdbusmenu-gtk3.so.4.0.5  /usr/lib/libgtksourceview-3.0.so.0
/usr/lib/libdbusmenu-gtk.so.4       /usr/lib/libgtksourceview-3.0.so.0.0.0
/usr/lib/libdbusmenu-gtk.so.4.0.5   /usr/lib/libgtkspell3.so.0
/usr/lib/libgdu-gtk.so.0            /usr/lib/libgtkspell3.so.0.0.0
/usr/lib/libgdu-gtk.so.0.0.0        /usr/lib/libgtkspell.so.0
/usr/lib/libgtk-3.a                 /usr/lib/libgtkspell.so.0.0.0
/usr/lib/libgtk-3.la                /usr/lib/libgtk-vnc-2.0.so.0
/usr/lib/libgtk-3.so                /usr/lib/libgtk-vnc-2.0.so.0.0.2
/usr/lib/libgtk-3.so.0              /usr/lib/libgwibber-gtk.so.2

2.10.0  modules

3.0.0  modules

gio-sharp.dll  gio-sharp.dll.config  gtk-sharp-beans.dll

gtk-query-immodules-3.0  gtk-update-icon-cache-3.0




Even if I need to convert the glade2 file to glade3 by hand I'm going to
have to have glade2
installed on the system in order to see what conversions I need to do.



On Mon, Nov 7, 2011 at 11:52 PM, Saku Masukita
<sakumasukita at googlemail.com>wrote:


A couple of years ago I was asking whether there would be
some tool to convert glade2 files to glade3 files but the answer
was negative (and that if anything such conversion must be part
of GTK+ and not glade). To date I still don't think such a tool exists.

Is there a script or an easy way out to carry out the conversion?



-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/glade-devel/attachments/20111108/630a4b8b/attachment.html 

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]