Re: [Gimp-developer] GIMP build: XDG_DATA_DIRS causing "Unrecognized image file format"

On 9/3/19 11:59 AM, Akkana Peck wrote:
Does setting
actually work for you, and you don't see the "Unrecognized image
file format" problem any more?

Well, it did work exactly as I posted. FWIW, just now I tried rebuilding GIMP-2.99 from scratch, starting from an empty install folder, but with the line 'XDG_DATA_DIRS="$XDG_DATA_DIRS:$PREFIX/share:/usr/local/share/:/usr/share/"' commented out. But the build failed at GEGL (terminal output is below). Whether this failure to build with the XDG line commented out is coincidence or not, I just don't know, haven't yet taken the time to figure it out.

What I do know is that building babl/GEGL/GIMP is getting increasingly complicated. It would be nice if the developers who are writing all this new code for GIMP-2.99 could provide up-to-date guidelines for building all this new code :) but I guess "how to build" varies a lot from one system (and day) to the next.

I do vaguely remember the issue you mentioned with not finding the image file formats. That was on Debian, but not the current version of Debian Sid. There was another issue? The same issue? - sorry, I don't remember - that I encountered recently on Debian Sid, where the advice from Hacking GIMP was contrary to what actually worked, though the Hacking GIMP advice had worked previously.

In case anyone has an idea what went wrong, here's the terminal output for the failed GEGL build:

elle@debian:~/code-build/gimp299/build/gegl/build$ ninja install
[214/750] Generating Gegl-0.4.gir with a custom command.
FAILED: gegl/Gegl-0.4.gir
/usr/bin/g-ir-scanner -pthread -I/usr/include/gobject-introspection-1.0 -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include --no-libtool --namespace=Gegl --nsversion=0.4 --warn-all --output gegl/Gegl-0.4.gir --c-include=gegl.h -I/media/data1/code-build/gimp299/build/gegl/gegl -I/media/data1/code-build/gimp299/build/gegl/build/gegl -I./. -I../. -I./gegl/. -I../gegl/. -I./gegl/buffer -I../gegl/buffer -I./gegl/graph -I../gegl/graph -I./gegl/module -I../gegl/module -I./gegl/opencl -I../gegl/opencl -I./gegl/operation -I../gegl/operation -I./gegl/process -I../gegl/process -I./gegl/property-types -I../gegl/property-types --filelist=/media/data1/code-build/gimp299/build/gegl/build/gegl/2cd4258@@gegl-0.4@sha/Gegl_0.4_gir_filelist --include=GLib-2.0 --include=GObject-2.0 --include=Babl-0.1 --symbol-prefix=gegl --identifier-prefix=Gegl --cflags-begin -DHAVE_CONFIG_H -Winit-self -Wmissing-declarations -Wmissing-prototypes -Wold-style-definition -Wpointer-arith -Wno-deprecated-declarations -mfpmath=sse -mmmx -msse -msse2 -msse4.1 -I./. -I../. -I./gegl/. -I../gegl/. -I./gegl/buffer -I../gegl/buffer -I./gegl/graph -I../gegl/graph -I./gegl/module -I../gegl/module -I./gegl/opencl -I../gegl/opencl -I./gegl/operation -I../gegl/operation -I./gegl/process -I../gegl/process -I./gegl/property-types -I../gegl/property-types -I/home/elle/code-install/gimp299/install/include/babl-0.1 -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/gio-unix-2.0 --cflags-end --library gegl-0.4 -L/media/data1/code-build/gimp299/build/gegl/build/gegl -L/home/elle/code-install/gimp299/install/lib/x86_64-linux-gnu -L/home/elle/code-install/gimp299/install/lib/x86_64-linux-gnu --extra-library=babl-0.1 --extra-library=glib-2.0 --extra-library=gio-2.0 --extra-library=gobject-2.0 --extra-library=m --extra-library=gmodule-2.0 Couldn't find include 'Babl-0.1.gir' (search path: '['gir-1.0', '/usr/share/gir-1.0', '/usr/share/gir-1.0', '/usr/share/gir-1.0']') [223/750] Generating module_common_gpl3.c with a custom command.
ninja: build stopped: subcommand failed.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]