[Gimp-developer] Cage transform and Warp transform

Hi All,

I wanted to somewhat reshape some curved lines in a drawing, and tried the Cage transform, which I remember using a long time ago. After selecting the points, it took a long time for the cage transform to calculate the cage. But when trying to move a point on the cage, nothing happened. During all of this calculating plus "nothing happened", these lines were printed over and over to the terminal:

(gimp-2.9:30657): GEGL-CRITICAL **: gegl_buffer_get: assertion 'GEGL_IS_BUFFER (buffer)' failed

Is there a bug? Or maybe I did something wrong? I reread through the on-line documentation (https://docs.gimp.org/2.9/en/gimp-tool-cage.html), but maybe I misunderstood what it says.

So I switched to the Warp transform, which worked very smoothly, quickly, responsively. It's like using a paint brush to warp the lines. The only catch was that after moving all the lines to where you want them, then you have to hit Return to actually apply the transform, which makes sense, but it took me a couple tries to figure this out.

Whoever programmed the warp transform, thank you!! This is such a nice way to gently reshape curved lines!

Jehan, is there any possibility that this warp transform could be made to work symmetrically, perhaps via the symmetric painting dialog? Or maybe it already does, but somehow I did something wrong?

Anyway, I made the transformed lines symmetric by duplicating the warped layer, flipping it around the horizontal axis, and applying a mask to hide the untranformed half of the image, which worked out just fine.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]